Skip to content

← Actionable
High, CVSS 7.5

Flight vulnerable to sensitive information disclosure via default error handler

CVE-2026-42552GHSA-qrch-52m5-vv85

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flightphp/core 3.18.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-42552: 0.34% estimated exploitation activity in the next 30 days; percentile 26.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The default error handler Engine::error() writes the full exception message, exception code, and stack trace (including absolute filesystem paths) directly into the HTTP 500 response, with no debug gating. Production deployments leak internal paths, any secret interpolated into an exception message, and full module structure — giving attackers primitives for chaining other weaknesses (LFI, path traversal). Affected code flight/Engine.php (≈ lines 678-704): No flight.debug check, no environment gating. Proof of concept Any uncaught exception — including those auto-raised from handleError() — returns: Reproduced against the live PoC app at /poc5/error. Impact - Disclosure of absolute filesystem paths (primes weaponization of LFI / path-traversal vulnerabilities in the same application). - Disclosure of secrets (DB credentials, API tokens) when exceptions are constructed with interpolated configuration values. - Enumeration of installed vendor packages and internal application…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qrch-52m5-vv85

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42552

Advisory: Flight vulnerable to sensitive information disclosure via default error handler
IDs: CVE-2026-42552, GHSA-qrch-52m5-vv85
Record: https://patchnext.com/advisories/cve-2026-42552 (revision 1, source checked 26 Oct 2026, 14:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flightphp/core 3.18.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist flightphp/core: affected < 3.18.1; fixed in 3.18.1

## Suggested inspection (read-only)
- Packagist flightphp/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flightphp/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qrch-52m5-vv85 (GitHub-reviewed advisory GHSA-qrch-52m5-vv85 lists affected ranges: Packagist flightphp/core >=0 <3.18.1)

Commands are suggestions: review each one before running it.

Loading voting…