Skip to content

← Actionable
High, CVSS 7.5

Flight: HTTP method override enabled by default, facilitating CSRF escalation and middleware bypass

CVE-2026-42551GHSA-vxrr-w42w-w76g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flightphp/core 3.18.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-42551: 0.35% estimated exploitation activity in the next 30 days; percentile 28.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Request::getMethod() unconditionally honors the X-HTTP-Method-Override header and the $REQUEST['method'] parameter on any HTTP verb (including safe verbs such as GET), with no opt-in and no whitelist of permitted target methods. A GET request can silently become a DELETE or PUT, enabling CSRF escalation against destructive endpoints, bypass of middleware gated on unsafe verbs, and cache poisoning between CDN and origin. Affected code flight/net/Request.php (≈ lines 281-292): $REQUEST aggregates $GET and $POST; on PHP runtimes with requestorder=GPC it also includes $COOKIE. Proof of concept is dispatched as DELETE /item/42. is also dispatched as DELETE /item/42. Trivial CSRF vector (no JavaScript required): loaded on any attacker-controlled page triggers the destructive DELETE on page load, bypassing Same-Origin Policy (image loads are not blocked). Reproduced against /poc4/item/42. Impact - GET → DELETE / PUT CSRF on any route registered for unsafe verbs. - Bypass of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vxrr-w42w-w76g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42551

Advisory: Flight: HTTP method override enabled by default, facilitating CSRF escalation and middleware bypass
IDs: CVE-2026-42551, GHSA-vxrr-w42w-w76g
Record: https://patchnext.com/advisories/cve-2026-42551 (revision 1, source checked 26 Oct 2026, 14:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flightphp/core 3.18.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist flightphp/core: affected < 3.18.1; fixed in 3.18.1

## Suggested inspection (read-only)
- Packagist flightphp/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flightphp/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vxrr-w42w-w76g (GitHub-reviewed advisory GHSA-vxrr-w42w-w76g lists affected ranges: Packagist flightphp/core >=0 <3.18.1)

Commands are suggestions: review each one before running it.

Loading voting…