Skip to content

← Actionable
High, CVSS 8.8

Flight vulnerable to SQL Injection via unvalidated identifiers in SimplePdo::insert / update / delete

CVE-2026-42550GHSA-xwqr-rcqg-22mr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flightphp/core 3.18.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-42550: 0.46% estimated exploitation activity in the next 30 days; percentile 39.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary SimplePdo::insert(), SimplePdo::update(), and SimplePdo::delete() build SQL statements by concatenating the $table argument and the keys of the $data array directly into the query, with no identifier quoting and no validation. When an application forwards user-controlled data shapes to these helpers — a common and documented pattern, e.g. $db-insert('users', $request-data-getData()) — an attacker can inject arbitrary SQL by crafting malicious array keys. Affected code flight/database/SimplePdo.php: No identifier-quoting helper exists; neither $table nor the data keys are validated against a safe-identifier pattern. Proof of concept A controller does: The attacker sends the JSON body: Generated SQL: After the -- comment, the effective statement INSERT INTO users (name, isadmin) VALUES (?, 1) binds the single placeholder 'attackerinjected', yielding a row with isadmin = 1. Reproduced live on an in-memory sqlite database (testproj/sqlilive2.php): UPDATE injection via the $where…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xwqr-rcqg-22mr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42550

Advisory: Flight vulnerable to SQL Injection via unvalidated identifiers in SimplePdo::insert / update / delete
IDs: CVE-2026-42550, GHSA-xwqr-rcqg-22mr
Record: https://patchnext.com/advisories/cve-2026-42550 (revision 1, source checked 26 Oct 2026, 14:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flightphp/core 3.18.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist flightphp/core: affected < 3.18.1; fixed in 3.18.1

## Suggested inspection (read-only)
- Packagist flightphp/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flightphp/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xwqr-rcqg-22mr (GitHub-reviewed advisory GHSA-xwqr-rcqg-22mr lists affected ranges: Packagist flightphp/core >=0 <3.18.1)

Commands are suggestions: review each one before running it.

Loading voting…