Skip to content

← Actionable
Medium, CVSS 5.9amended

Granian vulnerable to DoS via WSGI response header panic

CVE-2026-42545GHSA-f5p7-9fr5-8jmj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (granian 2.7.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI granian

    Affected
    >= 0.2.0, < 2.7.4
    Fixed in
    2.7.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-42545: 0.27% estimated exploitation activity in the next 30 days; percentile 19.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Granian aborts a worker process if a WSGI application returns an invalid HTTP response header name or value. The WSGI response conversion path uses .unwrap() on both the header name and header value constructors, so malformed output from the application becomes a process abort instead of a handled error. This issue requires a buggy or attacker-influenced WSGI application to emit invalid headers. It is not a parser bug in Granian's request path. The security impact is that application mistakes which should result in a 500 instead kill the worker process. Details https://github.com/emmett-framework/granian/blob/bdd5b0fbbb2aca6f2f4c0d2700c244d190958035/src/wsgi/io.rs#L39-L42 If either conversion fails, .unwrap() panics. In release builds Granian uses panic = "abort", so the panic terminates the worker. Preconditions The attacker must be able to influence a header name or value produced by the WSGI application, or the application must otherwise generate invalid headers. Examples…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-f5p7-9fr5-8jmj

  2. Revision 1 · created ·

    Published from osv record GHSA-f5p7-9fr5-8jmj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42545

Advisory: Granian vulnerable to DoS via WSGI response header panic
IDs: CVE-2026-42545, GHSA-f5p7-9fr5-8jmj
Record: https://patchnext.com/advisories/cve-2026-42545 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: granian 2.7.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI granian: affected >= 0.2.0, < 2.7.4; fixed in 2.7.4

## Suggested inspection (read-only)
- `python -m pip show granian`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on granian.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f5p7-9fr5-8jmj (OSV record GHSA-f5p7-9fr5-8jmj lists affected ranges: PyPI granian >=0.2.0 <2.7.4 (fixed))
- Verified: https://github.com/advisories/GHSA-f5p7-9fr5-8jmj (GitHub-reviewed advisory GHSA-f5p7-9fr5-8jmj lists affected ranges: PyPI granian >=0.2.0 <2.7.4)

Commands are suggestions: review each one before running it.

Loading voting…