Apache Airflow Amazon provider: Prevent unauthorized access to team-scoped secrets in AWS Secrets Manager and SSM Parameter Store backends
CVE-2026-42526GHSA-g9qc-qf28-hhqx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow-providers-amazon 9.28.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow-providers-amazon
- Affected
- < 9.28.0
- Fixed in
- 9.28.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g9qc-qf28-hhqx lists affected ranges: PyPI apache-airflow-providers-amazon >=0 <9.28.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g9qc-qf28-hhqx lists affected ranges: PyPI apache-airflow-providers-amazon >=0 <9.28.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-42526: 0.41% estimated exploitation activity in the next 30 days; percentile 35.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In the AWS Secrets Manager and SSM Parameter Store secrets backends of apache-airflow-providers-amazon prior to 9.28.0, the team-scoping logic could resolve a connid containing a / (e.g. "myteam/conn") to the same path as another team's team-scoped secret when the caller had no team context. A privileged caller without team context could therefore retrieve another team's secret by crafting a colliding connid. Fixed in 9.28.0 by switching the team-scope separator to -- and rejecting team-shaped connids when team context is absent. Affects the experimental multi-tenant teams feature only. Users are recommended to upgrade to apache-airflow-providers-amazon 9.28.0, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-g9qc-qf28-hhqx
- Revision 1 · created ·
Published from osv record GHSA-g9qc-qf28-hhqx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42526 Advisory: Apache Airflow Amazon provider: Prevent unauthorized access to team-scoped secrets in AWS Secrets Manager and SSM Parameter Store backends IDs: CVE-2026-42526, GHSA-g9qc-qf28-hhqx Record: https://patchnext.com/advisories/cve-2026-42526 (revision 2, source checked 26 Oct 2026, 13:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow-providers-amazon 9.28.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow-providers-amazon: affected < 9.28.0; fixed in 9.28.0 ## Suggested inspection (read-only) - `python -m pip show apache-airflow-providers-amazon`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow-providers-amazon. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g9qc-qf28-hhqx (OSV record GHSA-g9qc-qf28-hhqx lists affected ranges: PyPI apache-airflow-providers-amazon >=0 <9.28.0 (fixed)) - Verified: https://github.com/advisories/GHSA-g9qc-qf28-hhqx (GitHub-reviewed advisory GHSA-g9qc-qf28-hhqx lists affected ranges: PyPI apache-airflow-providers-amazon >=0 <9.28.0) Commands are suggestions: review each one before running it.
Loading voting…