Fedify has an LD-Signature Bypass via JSON-LD Named-Graph Restructuring
CVE-2026-42462GHSA-9rfg-v8g9-9367
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fedify/fedify 2.2.3, 2.1.14, 2.0.18, 1.10.10, 1.9.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @fedify/fedify
- Affected
- >= 2.2.0, < 2.2.3>= 2.1.0, < 2.1.14>= 2.0.0, < 2.0.18>= 1.10.0, < 1.10.10< 1.9.11
- Fixed in
- 1.9.11, 2.0.18, 1.10.10, 2.2.3, 2.1.14
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9rfg-v8g9-9367 lists affected ranges: npm @fedify/fedify >=2.2.0 =2.1.0 =2.0.0 =1.10.0 =0 <1.9.11 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9rfg-v8g9-9367 lists affected ranges: npm @fedify/fedify >=2.2.0 =2.1.0 =2.0.0 =1.10.0 =0 <1.9.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:L
- EPSS
- CVE-2026-42462: 0.17% estimated exploitation activity in the next 30 days; percentile 6.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
As told on Discord earlier, multiple projects are affected, and we would like to coordinate. For now, we are aiming at a May 6th release date, but this is not set in stone yet. Summary An attacker can make use of JSON-LD features to restructure a JSON-LD document that would change how Fedify interprets it without changing its Linked Data Signature, allowing them to alter a third-party signed activity they have received. Details The vulnerability essentially boils down to the signature being on the canonical RDF graph representation of the JSON-LD document, and JSON-LD offering many ways to represent the same graph. One of the issues is that by taking a signed Activity with an embedded object, an attacker can move the top-level Activity to a @graph property and move the activity's object to the top-level. Such a transformation preserves the signature and changes how the payload is interpreted by pretty much all ActivityPub implementations, making them process the object and ignore the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9rfg-v8g9-9367
- Revision 1 · created ·
Published from osv record GHSA-9rfg-v8g9-9367
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42462 Advisory: Fedify has an LD-Signature Bypass via JSON-LD Named-Graph Restructuring IDs: CVE-2026-42462, GHSA-9rfg-v8g9-9367 Record: https://patchnext.com/advisories/cve-2026-42462 (revision 2, source checked 26 Oct 2026, 12:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @fedify/fedify 2.2.3, 2.1.14, 2.0.18, 1.10.10, 1.9.11. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @fedify/fedify: affected >= 2.2.0, < 2.2.3; >= 2.1.0, < 2.1.14; >= 2.0.0, < 2.0.18; >= 1.10.0, < 1.10.10; < 1.9.11; fixed in 1.9.11, 2.0.18, 1.10.10, 2.2.3, 2.1.14 ## Suggested inspection (read-only) - `npm ls @fedify/fedify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @fedify/fedify. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9rfg-v8g9-9367 (OSV record GHSA-9rfg-v8g9-9367 lists affected ranges: npm @fedify/fedify >=2.2.0 =2.1.0 =2.0.0 =1.10.0 =0 <1.9.11 (fixed)) - Verified: https://github.com/advisories/GHSA-9rfg-v8g9-9367 (GitHub-reviewed advisory GHSA-9rfg-v8g9-9367 lists affected ranges: npm @fedify/fedify >=2.2.0 =2.1.0 =2.0.0 =1.10.0 =0 <1.9.11) Commands are suggestions: review each one before running it.
Loading voting…