Skip to content

← Actionable
High, CVSS 8.8amended

Apache Airflow has a Deserialization of Untrusted Data vulnerability

CVE-2026-42359GHSA-wr76-29cr-67w8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 3.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-42359: 0.57% estimated exploitation activity in the next 30 days; percentile 47.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A bug in Apache Airflow's XCom PATCH endpoint PATCH /api/v2/xcomEntries/{key} allowed an authenticated UI/API user with XCom write permission on a Dag to set XCom entries under reserved key names (e.g. returnvalue) that the matching POST endpoint already validated against FORBIDDENXCOMKEYS. The endpoint also accepted serialized payload shapes the triggerer's deserializer treats as code; combined, this allowed RCE on the triggerer when the affected task next deferred. Affects deployments where untrusted users have XCom write permission on Dags that defer to the triggerer. This is a fix-bypass of CVE-2026-33858: PR #64148 added the FORBIDDENXCOMKEYS validator only on the POST/set path; the PATCH path was not covered. Users who already upgraded for CVE-2026-33858 should additionally upgrade to apache-airflow 3.2.2 or later to cover the PATCH-path bypass.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wr76-29cr-67w8

  2. Revision 1 · created ·

    Published from osv record GHSA-wr76-29cr-67w8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42359

Advisory: Apache Airflow has a Deserialization of Untrusted Data vulnerability
IDs: CVE-2026-42359, GHSA-wr76-29cr-67w8
Record: https://patchnext.com/advisories/cve-2026-42359 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apache-airflow 3.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI apache-airflow: affected >= 3.2.0, < 3.2.2; fixed in 3.2.2

## Suggested inspection (read-only)
- `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apache-airflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wr76-29cr-67w8 (OSV record GHSA-wr76-29cr-67w8 lists affected ranges: PyPI apache-airflow >=3.2.0 <3.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-wr76-29cr-67w8 (GitHub-reviewed advisory GHSA-wr76-29cr-67w8 lists affected ranges: PyPI apache-airflow >=3.2.0 <3.2.2)

Commands are suggestions: review each one before running it.

Loading voting…