Sentry's improper authentication on SAML SSO process allows user identity linking
CVE-2026-42354GHSA-rcmw-7mc7-3rj7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sentry 26.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI sentry
- Affected
- >= 21.12.0, <= 26.4.0
- Fixed in
- 26.4.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rcmw-7mc7-3rj7 lists affected ranges: PyPI sentry >=21.12.0 <=26.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rcmw-7mc7-3rj7 lists affected ranges: PyPI sentry >=21.12.0 <26.4.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-42354: 0.62% estimated exploitation activity in the next 30 days; percentile 49.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A critical vulnerability was discovered in the SAML SSO implementation of Sentry. It was reported to us via Sentry's private bug bounty program. The vulnerability allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. The victim email address must be known in order to exploit this vulnerability. Self-hosted users are only vulnerable if the following conditions are met: - They have more than one organization configured (SENTRYSINGLEORGANIZATION = False). - A malicious user has existing access and permissions to modify SSO settings for another organization in their multi-organization instance. Patches - Sentry SaaS: The fix was deployed in April. No action is required. - Self-Hosted Sentry: If only a single organization is allowed (SENTRYSINGLEORGANIZATION = True), then no action is needed. Sentry recommends upgrading to version 26.4.1 or higher. Workarounds User account-based two-factor…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-rcmw-7mc7-3rj7
- Revision 2 · amended ·
Amended from osv record GHSA-rcmw-7mc7-3rj7
- Revision 1 · created ·
Published from ghsa record GHSA-rcmw-7mc7-3rj7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42354 Advisory: Sentry's improper authentication on SAML SSO process allows user identity linking IDs: CVE-2026-42354, GHSA-rcmw-7mc7-3rj7 Record: https://patchnext.com/advisories/cve-2026-42354 (revision 3, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sentry 26.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI sentry: affected >= 21.12.0, <= 26.4.0; fixed in 26.4.1 ## Suggested inspection (read-only) - `python -m pip show sentry`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sentry. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rcmw-7mc7-3rj7 (GitHub-reviewed advisory GHSA-rcmw-7mc7-3rj7 lists affected ranges: PyPI sentry >=21.12.0 <=26.4.0) - Verified: https://osv.dev/vulnerability/GHSA-rcmw-7mc7-3rj7 (OSV record GHSA-rcmw-7mc7-3rj7 lists affected ranges: PyPI sentry >=21.12.0 <26.4.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…