i18next-http-middleware has path traversal / SSRF via user-controlled language and namespace parameters
CVE-2026-42353GHSA-jfgf-83c5-2c4m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (i18next-http-middleware 3.9.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 3.9.3
- Fixed in
- 3.9.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jfgf-83c5-2c4m lists affected ranges: npm i18next-http-middleware >=0 <3.9.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jfgf-83c5-2c4m lists affected ranges: npm i18next-http-middleware >=0 <3.9.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2026-42353: 0.39% estimated exploitation activity in the next 30 days; percentile 32.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Versions of i18next-http-middleware prior to 3.9.3 pass the user-controlled lng and ns values from getResourcesHandler directly into i18next.services.backendConnector.load(languages, namespaces, …) without any sanitisation. Depending on which backend is configured, the unvalidated path segments enable one of two attacks: - Filesystem path traversal when the middleware is paired with i18next-fs-backend (or any backend that interpolates lng / ns into a filesystem path). - Server-Side Request Forgery (SSRF) when the middleware is paired with i18next-http-backend (or any backend that interpolates into an HTTP URL). Example request: with i18next-fs-backend reads the attacker-chosen file from disk; with i18next-http-backend reshapes the outgoing URL to target an internal service. Impact - Arbitrary file read via fs-style backends — any file the Node process can read becomes reachable (source, configuration, .ssh keys, .env, Docker secrets, etc.). - SSRF via http-style backends —…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jfgf-83c5-2c4m
- Revision 1 · created ·
Published from osv record GHSA-jfgf-83c5-2c4m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42353 Advisory: i18next-http-middleware has path traversal / SSRF via user-controlled language and namespace parameters IDs: CVE-2026-42353, GHSA-jfgf-83c5-2c4m Record: https://patchnext.com/advisories/cve-2026-42353 (revision 2, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: i18next-http-middleware 3.9.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm i18next-http-middleware: affected < 3.9.3; fixed in 3.9.3 ## Suggested inspection (read-only) - `npm ls i18next-http-middleware --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on i18next-http-middleware. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jfgf-83c5-2c4m (OSV record GHSA-jfgf-83c5-2c4m lists affected ranges: npm i18next-http-middleware >=0 <3.9.3 (fixed)) - Verified: https://github.com/advisories/GHSA-jfgf-83c5-2c4m (GitHub-reviewed advisory GHSA-jfgf-83c5-2c4m lists affected ranges: npm i18next-http-middleware >=0 <3.9.3) Commands are suggestions: review each one before running it.
Loading voting…