Skip to content

← Actionable
High, CVSS 7.5amended

pygeoapi 0.23.x: Path Traversal in STAC FileSystemProvider

CVE-2026-42351GHSA-f6pr-83pg-ghh6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pygeoapi 0.23.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pygeoapi

    Affected
    >= 0.23.0, < 0.23.3
    Fixed in
    0.23.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-42351: 0.51% estimated exploitation activity in the next 30 days; percentile 43.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A raw string path concatenation vulnerability in pygeoapi's STAC FileSystemProvider plugin can allow for requests to STAC collection based collections to expose directories without authentication. The issue manifests when pygeoapi is deployed without a proxy or web front end that would normalize URLs with .. values, along with a resource of type stac-collection defined in configuration. Patches The issue has been patched in master branch and made available as part of the 0.23.3 release. The commit/fix can be found in bf25b8695edbdd5476eeffc102b633d1d3e45f52. Workarounds Users can safeguard existing applications by disabling STAC collection based resources in their pygeoapi config, until 0.23.3 can be installed and deployed.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-f6pr-83pg-ghh6

  2. Revision 1 · created ·

    Published from osv record GHSA-f6pr-83pg-ghh6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42351

Advisory: pygeoapi 0.23.x: Path Traversal in STAC FileSystemProvider
IDs: CVE-2026-42351, GHSA-f6pr-83pg-ghh6
Record: https://patchnext.com/advisories/cve-2026-42351 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pygeoapi 0.23.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pygeoapi: affected >= 0.23.0, < 0.23.3; fixed in 0.23.3

## Suggested inspection (read-only)
- `python -m pip show pygeoapi`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pygeoapi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f6pr-83pg-ghh6 (OSV record GHSA-f6pr-83pg-ghh6 lists affected ranges: PyPI pygeoapi >=0.23.0 <0.23.3 (fixed))
- Verified: https://github.com/advisories/GHSA-f6pr-83pg-ghh6 (GitHub-reviewed advisory GHSA-f6pr-83pg-ghh6 lists affected ranges: PyPI pygeoapi >=0.23.0 <0.23.3)

Commands are suggestions: review each one before running it.

Loading voting…