go-ipld-prime's DAG-CBOR and DAG-JSON decoders have unbounded recursion depth
CVE-2026-42328GHSA-w239-58x2-q8p5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/ipld/go-ipld-prime 0.23.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/ipld/go-ipld-prime
- Affected
- < 0.23.0
- Fixed in
- 0.23.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w239-58x2-q8p5 lists affected ranges: Go github.com/ipld/go-ipld-prime >=0 <0.23.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.2 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-42328: 0.12% estimated exploitation activity in the next 30 days; percentile 1.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The DAG-CBOR and DAG-JSON decoders recurse on each nested map or list without a depth limit. A payload containing deeply nested collections causes the decoder to recurse once per level, growing the goroutine stack until the Go runtime terminates the process with a fatal stack overflow (distinct from a recoverable panic). For DAG-CBOR, a payload of approximately 2 MB, consisting of repeated 0x81 (array-of-1) bytes followed by a terminator, produces around 2 million recursion frames and reliably exhausts Go's default 1 GB goroutine stack. The existing allocation budget does not prevent this: each nested collection header costs only a handful of budget units, so the stack is exhausted before the budget is. DAG-JSON has equivalent exposure via [[[...]]]-style payloads; it has no budget system and is therefore unprotected against recursion depth as well. Schema-free decoding (using basicnode.Prototype.Any) allows arbitrary nesting depth. Schema-bound decoding bounds nesting only when the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w239-58x2-q8p5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42328 Advisory: go-ipld-prime's DAG-CBOR and DAG-JSON decoders have unbounded recursion depth IDs: CVE-2026-42328, GHSA-w239-58x2-q8p5 Record: https://patchnext.com/advisories/cve-2026-42328 (revision 1, source checked 26 Oct 2026, 15:23 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/ipld/go-ipld-prime 0.23.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/ipld/go-ipld-prime: affected < 0.23.0; fixed in 0.23.0 ## Suggested inspection (read-only) - Go github.com/ipld/go-ipld-prime: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/ipld/go-ipld-prime. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w239-58x2-q8p5 (GitHub-reviewed advisory GHSA-w239-58x2-q8p5 lists affected ranges: Go github.com/ipld/go-ipld-prime >=0 <0.23.0) Commands are suggestions: review each one before running it.
Loading voting…