Skip to content

← Actionable
Medium, CVSS 6.8amended

pyload-ng: non-admin SETTINGS users can disable outbound TLS peer verification via unrestricted ssl_verify config (incomplete fix for CVE-2026-33509 / -35463 / -35464 / -35586)

CVE-2026-42312GHSA-ccxc-x975-4hh9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyload-ng 0.5.0b3.dev100), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyload-ng

    Affected
    <= 0.5.0b3.dev99
    Fixed in
    0.5.0b3.dev100

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-42312: 0.17% estimated exploitation activity in the next 30 days; percentile 6.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The setconfigvalue() API method (@permission(Perms.SETTINGS)) in src/pyload/core/api/init.py gates security-sensitive options behind a hand-maintained allowlist ADMINONLYCOREOPTIONS. The option ("general", "sslverify") is not on that allowlist. Any authenticated user with the non-admin SETTINGS permission can set general.sslverify = off, and every subsequent outbound pycurl request is made with SSLVERIFYPEER=0 and SSLVERIFYHOST=0 — TLS peer and hostname verification are fully disabled. An on-path attacker can then present forged certificates for any hostname pyload fetches. This is a direct continuation of the fix family CVE-2026-33509 / CVE-2026-35463 / CVE-2026-35464 / CVE-2026-35586, each of which patched a different missed option in the same allowlist. Details Writer — src/pyload/core/api/init.py, setconfigvalue() (around lines 215–290). The function is decorated with @permission(Perms.SETTINGS) and only rejects writes when (category, option) appears in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-ccxc-x975-4hh9

  2. Revision 1 · created ·

    Published from osv record GHSA-ccxc-x975-4hh9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42312

Advisory: pyload-ng: non-admin SETTINGS users can disable outbound TLS peer verification via unrestricted `ssl_verify` config (incomplete fix for CVE-2026-33509 / -35463 / -35464 / -35586)
IDs: CVE-2026-42312, GHSA-ccxc-x975-4hh9
Record: https://patchnext.com/advisories/cve-2026-42312 (revision 2, source checked 26 Oct 2026, 13:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyload-ng 0.5.0b3.dev100. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyload-ng: affected <= 0.5.0b3.dev99; fixed in 0.5.0b3.dev100

## Suggested inspection (read-only)
- `python -m pip show pyload-ng`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyload-ng.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-ccxc-x975-4hh9 (OSV record GHSA-ccxc-x975-4hh9 lists affected ranges: PyPI pyload-ng >=0 <0.5.0b3.dev100 (fixed))
- Verified: https://github.com/advisories/GHSA-ccxc-x975-4hh9 (GitHub-reviewed advisory GHSA-ccxc-x975-4hh9 lists affected ranges: PyPI pyload-ng >=0 <=0.5.0b3.dev99)

Commands are suggestions: review each one before running it.

Loading voting…