Skip to content

← Actionable
Medium, CVSS 5.1amended

Pillow has a PDF Parsing Trailer Infinite Loop (DoS)

CVE-2026-42310GHSA-r73j-pqj5-w3x7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pillow 12.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pillow

    Affected
    >= 4.2.0, < 12.2.0
    Fixed in
    12.2.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-42310: 0.17% estimated exploitation activity in the next 30 days; percentile 6.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An attacker can supply a malicious PDF that causes the process to hang indefinitely, consuming 100% CPU and making the application unresponsive. Patches Patched version: 12.2.0. PdfParser (introduced in Pillow 4.2.0) follows Prev pointers in PDF trailers to read cross-reference sections. If a trailer's Prev pointer references an offset that has already been processed — either pointing to itself or forming a longer cycle — the parser enters an infinite loop. Pillow now tracks previously processed trailer offsets and raises an error if a cycle is detected. Workarounds Use any version but the affected versions: = 4.2.0, < 12.2.0 Resources - Fix: https://github.com/python-pillow/Pillow/pull/9519

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-r73j-pqj5-w3x7

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-r73j-pqj5-w3x7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42310

Advisory: Pillow has a PDF Parsing Trailer Infinite Loop (DoS)
IDs: CVE-2026-42310, GHSA-r73j-pqj5-w3x7
Record: https://patchnext.com/advisories/cve-2026-42310 (revision 3, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pillow 12.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pillow: affected >= 4.2.0, < 12.2.0; fixed in 12.2.0

## Suggested inspection (read-only)
- `python -m pip show pillow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pillow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r73j-pqj5-w3x7 (OSV record GHSA-r73j-pqj5-w3x7 lists affected ranges: PyPI pillow >=4.2.0 <12.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-r73j-pqj5-w3x7 (GitHub-reviewed advisory GHSA-r73j-pqj5-w3x7 lists affected ranges: PyPI pillow >=4.2.0 <12.2.0)

Commands are suggestions: review each one before running it.

Loading voting…