Ethyca Fides has a Privacy Request Identity Verification Bypass Vulnerability via Duplicate Detection
CVE-2026-42303GHSA-qx5f-ghc2-7g5c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ethyca-fides 2.83.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ethyca-fides
- Affected
- >= 2.75.0, < 2.83.2
- Fixed in
- 2.83.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qx5f-ghc2-7g5c lists affected ranges: PyPI ethyca-fides >=2.75.0 <2.83.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qx5f-ghc2-7g5c lists affected ranges: PyPI ethyca-fides >=2.75.0 <2.83.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:N/SI:H/SA:N · score source
- EPSS
- CVE-2026-42303: 0.31% estimated exploitation activity in the next 30 days; percentile 23.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Fides deployments that enable both subject identity verification and duplicate privacy request detection are affected by a vulnerability in which an administrator can approve a privacy request whose identity was never verified. For erasure policies, this can result in unauthorized deletion of a data subject's records across every integration configured in the affected deployment. A related lower-severity denial-of-service issue, in which an unauthenticated attacker could prevent a legitimate data subject from completing their own privacy requests, is also patched in the fix for this vulnerability. Am I affected? This vulnerability only affects deployments that use Fides's privacy request (data subject request) features, also known collectively as "Lethe". Deployments that do not submit, process, or manage privacy requests through Fides are not affected. Within deployments that do use privacy request features, your deployment is affected if both of the following settings are…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-qx5f-ghc2-7g5c
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-qx5f-ghc2-7g5c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42303 Advisory: Ethyca Fides has a Privacy Request Identity Verification Bypass Vulnerability via Duplicate Detection IDs: CVE-2026-42303, GHSA-qx5f-ghc2-7g5c Record: https://patchnext.com/advisories/cve-2026-42303 (revision 3, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ethyca-fides 2.83.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ethyca-fides: affected >= 2.75.0, < 2.83.2; fixed in 2.83.2 ## Suggested inspection (read-only) - `python -m pip show ethyca-fides`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ethyca-fides. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qx5f-ghc2-7g5c (OSV record GHSA-qx5f-ghc2-7g5c lists affected ranges: PyPI ethyca-fides >=2.75.0 <2.83.2 (fixed)) - Verified: https://github.com/advisories/GHSA-qx5f-ghc2-7g5c (GitHub-reviewed advisory GHSA-qx5f-ghc2-7g5c lists affected ranges: PyPI ethyca-fides >=2.75.0 <2.83.2) Commands are suggestions: review each one before running it.
Loading voting…