pyp2spec is Vulnerable to Code Injection
CVE-2026-42301GHSA-r35x-v8p8-xvhw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyp2spec 0.14.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pyp2spec
- Affected
- < 0.14.1
- Fixed in
- 0.14.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r35x-v8p8-xvhw lists affected ranges: PyPI pyp2spec >=0 <0.14.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r35x-v8p8-xvhw lists affected ranges: PyPI pyp2spec >=0 <0.14.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-42301: 0.20% estimated exploitation activity in the next 30 days; percentile 9.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact pyp2spec was writing PyPI package metadata (e.g. the summary field) into the generated spec file without escaping RPM macro directives. When a packager then runs rpmbuild, those directives get evaluated, so a malicious package can execute arbitrary commands on the build machine. The macro evaluates during spec parsing, not only during the build step. Any rpm tool touching the generated spec triggers execution, rpmbuild -bs, rpmbuild --nobuild, rpm -q --specfile, so the victim doesn't need to commit to a full build before getting compromised. The realistic attack path is typosquatting or targeting a package known to be under Fedora review rather than drive-by publishing. Fedora packagers hold dist-git SSH keys, Koji build credentials, and Bodhi update credentials, so compromise of one packager's workstation enables committing malicious source to dist-git and riding it through the normal build pipeline to end users. Patches Patched in 0.14.1. Workarounds None
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-r35x-v8p8-xvhw
- Revision 1 · created ·
Published from osv record GHSA-r35x-v8p8-xvhw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42301 Advisory: pyp2spec is Vulnerable to Code Injection IDs: CVE-2026-42301, GHSA-r35x-v8p8-xvhw Record: https://patchnext.com/advisories/cve-2026-42301 (revision 2, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pyp2spec 0.14.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pyp2spec: affected < 0.14.1; fixed in 0.14.1 ## Suggested inspection (read-only) - `python -m pip show pyp2spec`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pyp2spec. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r35x-v8p8-xvhw (OSV record GHSA-r35x-v8p8-xvhw lists affected ranges: PyPI pyp2spec >=0 <0.14.1 (fixed)) - Verified: https://github.com/advisories/GHSA-r35x-v8p8-xvhw (GitHub-reviewed advisory GHSA-r35x-v8p8-xvhw lists affected ranges: PyPI pyp2spec >=0 <0.14.1) Commands are suggestions: review each one before running it.
Loading voting…