Skip to content

← Actionable
High, CVSS 7.8amended

protobuf.js is Vulnerable to OS Command Injection in the CLI

CVE-2026-42290GHSA-f84p-cvgm-xgjj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (protobufjs-cli 2.0.2, 1.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm protobufjs-cli

    Affected
    <= 1.2.0>= 2.0.0, <= 2.0.1
    Fixed in
    2.0.2, 1.2.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-42290: 0.13% estimated exploitation activity in the next 30 days; percentile 2.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary pbts invoked JSDoc by building a shell command string from input file paths and executing it through childprocess.exec. File paths containing shell metacharacters could therefore be interpreted by the shell instead of being passed to JSDoc as plain arguments. Impact An attacker who can control file names or paths passed to pbts may be able to execute arbitrary shell commands with the privileges of the process running pbts. This affects the protobufjs CLI tooling path. The protobufjs runtime APIs for encoding, decoding, parsing, and loading protobuf messages are not directly affected by this issue. Preconditions - The application or user must invoke pbts on file paths influenced by an attacker. - The attacker must be able to supply or create a path containing shell-significant characters. - The vulnerable pbts version must execute the generated JSDoc command through a shell. Workarounds Do not run affected versions of pbts on attacker-controlled file names or paths. If this…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-f84p-cvgm-xgjj

  2. Revision 1 · created ·

    Published from osv record GHSA-f84p-cvgm-xgjj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42290

Advisory: protobuf.js is Vulnerable to OS Command Injection in the CLI
IDs: CVE-2026-42290, GHSA-f84p-cvgm-xgjj
Record: https://patchnext.com/advisories/cve-2026-42290 (revision 2, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: protobufjs-cli 2.0.2, 1.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm protobufjs-cli: affected <= 1.2.0; >= 2.0.0, <= 2.0.1; fixed in 2.0.2, 1.2.1

## Suggested inspection (read-only)
- `npm ls protobufjs-cli --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on protobufjs-cli.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f84p-cvgm-xgjj (OSV record GHSA-f84p-cvgm-xgjj lists affected ranges: npm protobufjs-cli >=0 =2.0.0 <2.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-f84p-cvgm-xgjj (GitHub-reviewed advisory GHSA-f84p-cvgm-xgjj lists affected ranges: npm protobufjs-cli >=0 =2.0.0 <=2.0.1)

Commands are suggestions: review each one before running it.

Loading voting…