Skip to content

← Actionable
Medium, CVSS 4.3amended

n8n-MCP: Sensitive MCP tool-call arguments logged on authenticated requests in HTTP mode

CVE-2026-42282GHSA-wg4g-395p-mqv3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n-mcp 2.47.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n-mcp

    Affected
    < 2.47.13
    Fixed in
    2.47.13

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-42282: 0.25% estimated exploitation activity in the next 30 days; percentile 16.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When n8n-mcp runs in HTTP transport mode, authenticated MCP tools/call requests had their full arguments and JSON-RPC params written to server logs by the request dispatcher and several sibling code paths before any redaction. When a tool call carries credential material — most notably n8nmanagecredentials.data — the raw values can be persisted in logs. In deployments where logs are collected, forwarded to external systems, or viewable outside the request trust boundary (shared log storage, SIEM pipelines, support/ops access), this can result in disclosure of: - bearer tokens and OAuth credentials sent through n8nmanagecredentials - per-tenant API keys and webhook auth headers embedded in tool arguments - arbitrary secret-bearing payloads passed to any MCP tool The issue requires authentication (AUTHTOKEN accepted by the server), so unauthenticated callers cannot trigger it; the runtime exposure is also reduced by an existing console-silencing layer in HTTP mode, but that…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wg4g-395p-mqv3

  2. Revision 1 · created ·

    Published from osv record GHSA-wg4g-395p-mqv3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42282

Advisory: n8n-MCP: Sensitive MCP tool-call arguments logged on authenticated requests in HTTP mode
IDs: CVE-2026-42282, GHSA-wg4g-395p-mqv3
Record: https://patchnext.com/advisories/cve-2026-42282 (revision 2, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n-mcp 2.47.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n-mcp: affected < 2.47.13; fixed in 2.47.13

## Suggested inspection (read-only)
- `npm ls n8n-mcp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n-mcp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wg4g-395p-mqv3 (OSV record GHSA-wg4g-395p-mqv3 lists affected ranges: npm n8n-mcp >=0 <2.47.13 (fixed))
- Verified: https://github.com/advisories/GHSA-wg4g-395p-mqv3 (GitHub-reviewed advisory GHSA-wg4g-395p-mqv3 lists affected ranges: npm n8n-mcp >=0 <2.47.13)

Commands are suggestions: review each one before running it.

Loading voting…