Skip to content

← Actionable
Critical, CVSS 9.2amended

MagicMirror vulnerable to unauthenticated SSRF via /cors endpoint

CVE-2026-42281GHSA-ph6f-2cvq-79hq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (magicmirror 2.36.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2026-42281: 1.62% estimated exploitation activity in the next 30 days; percentile 76.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An unauthenticated Server-Side Request Forgery (SSRF) vulnerability in the /cors endpoint allows any remote attacker to force the MagicMirror² server to perform arbitrary HTTP requests to internal networks, cloud metadata services, and localhost services. The endpoint also expands environment variable placeholders (VARNAME), enabling exfiltration of server-side secrets. Details The /cors endpoint in js/serverfunctions.js (function cors(), lines 37-78) acts as an open HTTP proxy with no authentication and no URL validation. Any user-supplied URL is fetched server-side via fetch() and the full response is returned to the caller. Additionally, the replaceSecretPlaceholder() function (lines 21-25) expands any VARIABLENAME pattern in the URL with the corresponding process.env value before the request is made, allowing an attacker to exfiltrate environment variables (e.g. API keys, tokens, database credentials). Vulnerable code path: Key issues: - No authentication required - No…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-ph6f-2cvq-79hq

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-ph6f-2cvq-79hq

  4. Revision 1 · created ·

    Published from ghsa record GHSA-ph6f-2cvq-79hq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42281

Advisory: MagicMirror vulnerable to unauthenticated SSRF via /cors endpoint
IDs: CVE-2026-42281, GHSA-ph6f-2cvq-79hq
Record: https://patchnext.com/advisories/cve-2026-42281 (revision 4, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: magicmirror 2.36.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm magicmirror: affected <= 2.35.0; fixed in 2.36.0

## Suggested inspection (read-only)
- `npm ls magicmirror --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on magicmirror.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-ph6f-2cvq-79hq (GitHub-reviewed advisory GHSA-ph6f-2cvq-79hq lists affected ranges: npm magicmirror >=0 <=2.35.0)
- Verified: https://osv.dev/vulnerability/GHSA-ph6f-2cvq-79hq (OSV record GHSA-ph6f-2cvq-79hq lists affected ranges: npm magicmirror >=0 <2.36.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…