Skip to content

← Actionable
High, CVSS 7.1amended

Auth.js SDK has Improper Permission Checking

CVE-2026-42280GHSA-8qjv-jj2q-x832

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (auth0-js 10.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm auth0-js

    Affected
    >= 8.11.0, <= 9.32.0
    Fixed in
    10.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
EPSS
  • CVE-2026-42280: 0.21% estimated exploitation activity in the next 30 days; percentile 11.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description Under specific preconditions, the Auth0.js SDK may improperly return user profile information using a valid access token when a specifically crafted invalid ID token is provided. Am I Affected? Users are affected if they meet each of the following preconditions: - Applications built using Auth0.js version between 8.11.0 and 9.32.0 - The application’s access control relies on rules defined in Auth0 Actions. Affected product and versions auth0.js SDK v8.11.0 to v9.32.0 Resolution Upgrade auth0/auth0.js to v10.0.0 or greater. Acknowledgements Okta would like to thank Quan Le (@aleister1102) for their discovery and responsible disclosure.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8qjv-jj2q-x832

  2. Revision 1 · created ·

    Published from osv record GHSA-8qjv-jj2q-x832

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42280

Advisory: Auth.js SDK has Improper Permission Checking
IDs: CVE-2026-42280, GHSA-8qjv-jj2q-x832
Record: https://patchnext.com/advisories/cve-2026-42280 (revision 2, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: auth0-js 10.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm auth0-js: affected >= 8.11.0, <= 9.32.0; fixed in 10.0.0

## Suggested inspection (read-only)
- `npm ls auth0-js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on auth0-js.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8qjv-jj2q-x832 (OSV record GHSA-8qjv-jj2q-x832 lists affected ranges: npm auth0-js >=8.11.0 <10.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-8qjv-jj2q-x832 (GitHub-reviewed advisory GHSA-8qjv-jj2q-x832 lists affected ranges: npm auth0-js >=8.11.0 <=9.32.0)

Commands are suggestions: review each one before running it.

Loading voting…