Skip to content

← Actionable
High, CVSS 8.7Exploited · CISA KEVamended

LiteLLM: Authenticated command execution via MCP stdio test endpoints

CVE-2026-42271GHSA-v4p8-mg3p-g94g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (litellm 1.83.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI litellm

    Affected
    >= 1.74.2, < 1.83.7
    Fixed in
    1.83.7

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2026-42271: 91.44% estimated exploitation activity in the next 30 days; percentile 99.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. Patches Fixed in 1.83.7. Both test endpoints now require the PROXYADMIN role, bringing them into line with the save endpoint. Workarounds If upgrading is not immediately possible, developers should block POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list at their reverse proxy or API gateway.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-v4p8-mg3p-g94g

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · evidence added ·

    CISA KEV confirmed exploitation for CVE-2026-42271 (date added 2026-06-08). Customer workflow unchanged.

  4. Revision 1 · created ·

    Published from osv record GHSA-v4p8-mg3p-g94g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42271

Advisory: LiteLLM: Authenticated command execution via MCP stdio test endpoints
IDs: CVE-2026-42271, GHSA-v4p8-mg3p-g94g
Record: https://patchnext.com/advisories/cve-2026-42271 (revision 4, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: litellm 1.83.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI litellm: affected >= 1.74.2, < 1.83.7; fixed in 1.83.7

## Suggested inspection (read-only)
- `python -m pip show litellm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on litellm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v4p8-mg3p-g94g (OSV record GHSA-v4p8-mg3p-g94g lists affected ranges: PyPI litellm >=1.74.2 <1.83.7 (fixed))
- Verified: https://www.cisa.gov/sites/default/files/feeds/known_exploited_vulnerabilities.json (CISA added CVE-2026-42271 to the Known Exploited Vulnerabilities catalog on 2026-06-08.)
- Verified: https://github.com/advisories/GHSA-v4p8-mg3p-g94g (GitHub-reviewed advisory GHSA-v4p8-mg3p-g94g lists affected ranges: PyPI litellm >=1.74.2 <1.83.7)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2026-42271 to the Known Exploited Vulnerabilities catalog on 2026-06-08.)

Commands are suggestions: review each one before running it.

Loading voting…