Skip to content

← Actionable
High, CVSS 8.8amended

JupyterLab has an Extension Manager API/GUI Policy Discrepancy, allowing 3rd party (malicious) extensions install via POST request

CVE-2026-42266GHSA-37w4-hwhx-4rc4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyterlab 4.5.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI jupyterlab

    Affected
    >= 4.0.0, <= 4.5.6
    Fixed in
    4.5.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-42266: 5.65% estimated exploitation activity in the next 30 days; percentile 92.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The allow-list of extensions that can be installed from PyPI Extension Manager (allowedextensionsuris) is not correctly enforced by JupyterLab prior to 4.5.7. The PyPI Extension Manager was not contained to packages listed on the default PyPI index. This has security implications for deployments that: - have allow-listed specific extensions with aim to prevent users from installing packages - have the kernel and terminals disabled or delegated to remote hosts (thus no access to install packages in the single-user server environment) - have multi-tenant deployments that is not configured for untrusted users (as per documented on JupyterHub https://jupyterhub.readthedocs.io/en/5.2.1/explanation/websecurity.html) - have the (default) PyPI Extension Manager enabled Impact An authenticated attacker - such as a student in a shared JupyterHub environment or a user in a multi-tenant JupyterLab deployment - can escalate their privileges. This might allow for data exfiltration, lateral…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-37w4-hwhx-4rc4

  2. Revision 1 · created ·

    Published from osv record GHSA-37w4-hwhx-4rc4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42266

Advisory: JupyterLab has an Extension Manager API/GUI Policy Discrepancy, allowing 3rd party (malicious) extensions install via POST request
IDs: CVE-2026-42266, GHSA-37w4-hwhx-4rc4
Record: https://patchnext.com/advisories/cve-2026-42266 (revision 2, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jupyterlab 4.5.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI jupyterlab: affected >= 4.0.0, <= 4.5.6; fixed in 4.5.7

## Suggested inspection (read-only)
- `python -m pip show jupyterlab`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jupyterlab.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-37w4-hwhx-4rc4 (OSV record GHSA-37w4-hwhx-4rc4 lists affected ranges: PyPI jupyterlab >=4.0.0 <4.5.7 (fixed))
- Verified: https://github.com/advisories/GHSA-37w4-hwhx-4rc4 (GitHub-reviewed advisory GHSA-37w4-hwhx-4rc4 lists affected ranges: PyPI jupyterlab >=4.0.0 <=4.5.6)

Commands are suggestions: review each one before running it.

Loading voting…