Skip to content

← Actionable
High, CVSS 7.4amended

Axios has prototype pollution read-side gadgets in HTTP adapter that allow credential injection and request hijacking

CVE-2026-42264GHSA-q8qp-cvcw-x6jj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (axios 1.15.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm axios

    Affected
    >= 1.0.0, < 1.15.2
    Fixed in
    1.15.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-42264: 0.80% estimated exploitation activity in the next 30 days; percentile 56.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Five config properties in the HTTP adapter are read via direct property access without hasOwnProperty guards, making them exploitable as prototype pollution gadgets. When Object.prototype is polluted by another dependency in the same process, axios silently picks up these polluted values on every outbound HTTP request. Affected Properties 1. config.auth (lib/adapters/http.js line 617) Injects attacker-controlled Authorization header on all requests. 2. config.baseURL (lib/helpers/resolveConfig.js line 18) Redirects all requests using relative URLs to an attacker-controlled server. 3. config.socketPath (lib/adapters/http.js line 669) Redirects requests to internal Unix sockets (e.g. Docker daemon). 4. config.beforeRedirect (lib/adapters/http.js line 698) Executes attacker-supplied callback during HTTP redirects. 5. config.insecureHTTPParser (lib/adapters/http.js line 712) Enables Node.js insecure HTTP parser on all requests. Proof of Concept Impact - Credential injection:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-q8qp-cvcw-x6jj

  2. Revision 1 · created ·

    Published from osv record GHSA-q8qp-cvcw-x6jj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42264

Advisory: Axios has prototype pollution read-side gadgets in HTTP adapter that allow credential injection and request hijacking
IDs: CVE-2026-42264, GHSA-q8qp-cvcw-x6jj
Record: https://patchnext.com/advisories/cve-2026-42264 (revision 2, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: axios 1.15.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm axios: affected >= 1.0.0, < 1.15.2; fixed in 1.15.2

## Suggested inspection (read-only)
- `npm ls axios --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on axios.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q8qp-cvcw-x6jj (OSV record GHSA-q8qp-cvcw-x6jj lists affected ranges: npm axios >=1.0.0 <1.15.2 (fixed))
- Verified: https://github.com/advisories/GHSA-q8qp-cvcw-x6jj (GitHub-reviewed advisory GHSA-q8qp-cvcw-x6jj lists affected ranges: npm axios >=1.0.0 <1.15.2)

Commands are suggestions: review each one before running it.

Loading voting…