Saltcorn: Open Redirect in POST /auth/login due to incomplete is_relative_url validation (backslash bypass)
CVE-2026-42259GHSA-f3g8-9xv5-77gv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@saltcorn/server 1.6.0-beta.5, 1.5.6, 1.4.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @saltcorn/server
- Affected
- < 1.4.6>= 1.5.0-beta.0, < 1.5.6>= 1.6.0-alpha.0, < 1.6.0-beta.5
- Fixed in
- 1.6.0-beta.5, 1.4.6, 1.5.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f3g8-9xv5-77gv lists affected ranges: npm @saltcorn/server >=0 =1.5.0-beta.0 =1.6.0-alpha.0 <1.6.0-beta.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f3g8-9xv5-77gv lists affected ranges: npm @saltcorn/server >=0 =1.5.0-beta.0 =1.6.0-alpha.0 <1.6.0-beta.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-42259: 0.34% estimated exploitation activity in the next 30 days; percentile 27.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Saltcorn validates the post-login dest parameter with a string check that only blocks :/ and //. Because all WHATWG-compliant browsers normalise backslashes (\) to forward slashes (/) for special schemes, a payload such as /\evil.com/path slips through isrelativeurl(), is emitted unchanged in the HTTP Location header, and causes the browser to navigate cross-origin to an attacker-controlled domain. The bug is reachable on a default install and only requires a victim who can be tricked into logging in via a crafted Saltcorn URL. Details Vulnerable function: packages/server/routes/utils.js:393-395 The function's intent is to allow only same-origin redirects, but the allow-list only checks for two literal substrings. It does not handle: - backslash characters, which WHATWG URL parsing (used by every modern browser) treats as forward slashes for the special schemes http, https, ftp, ws, wss. A URL parser fed /\evil.com/path with a base of http://victim/ resolves to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-f3g8-9xv5-77gv
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-f3g8-9xv5-77gv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42259 Advisory: Saltcorn: Open Redirect in `POST /auth/login` due to incomplete `is_relative_url` validation (backslash bypass) IDs: CVE-2026-42259, GHSA-f3g8-9xv5-77gv Record: https://patchnext.com/advisories/cve-2026-42259 (revision 3, source checked 26 Oct 2026, 12:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @saltcorn/server 1.6.0-beta.5, 1.5.6, 1.4.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @saltcorn/server: affected < 1.4.6; >= 1.5.0-beta.0, < 1.5.6; >= 1.6.0-alpha.0, < 1.6.0-beta.5; fixed in 1.6.0-beta.5, 1.4.6, 1.5.6 ## Suggested inspection (read-only) - `npm ls @saltcorn/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @saltcorn/server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-f3g8-9xv5-77gv (OSV record GHSA-f3g8-9xv5-77gv lists affected ranges: npm @saltcorn/server >=0 =1.5.0-beta.0 =1.6.0-alpha.0 <1.6.0-beta.5 (fixed)) - Verified: https://github.com/advisories/GHSA-f3g8-9xv5-77gv (GitHub-reviewed advisory GHSA-f3g8-9xv5-77gv lists affected ranges: npm @saltcorn/server >=0 =1.5.0-beta.0 =1.6.0-alpha.0 <1.6.0-beta.5) Commands are suggestions: review each one before running it.
Loading voting…