net-imap vulnerable to command Injection via "raw" arguments to multiple commands
CVE-2026-42257GHSA-hm49-wcqc-g2xg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (net-imap 0.6.4, 0.5.14, 0.4.24), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems net-imap
- Affected
- >= 0.6.0, <= 0.6.3>= 0.5.0, <= 0.5.13<= 0.4.23
- Fixed in
- 0.6.4, 0.5.14, 0.4.24
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hm49-wcqc-g2xg lists affected ranges: RubyGems net-imap >=0.6.0 =0.5.0 =0 <=0.4.23
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.8 · CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-42257: 0.43% estimated exploitation activity in the next 30 days; percentile 37.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Several Net::IMAP commands accept a raw string argument that is sent to the server without validation or escaping. If this string is derived from user-controlled input, it may contain contain CRLF sequences, which an attacker can use to inject arbitrary IMAP commands. Details Net::IMAP's generic argument handling, used by most command arguments, interprets string arguments as an IMAP astring. Depending on the string contents and the connection's UTF-8 support, this encodes strings as either a atom, quoted, or literal. These are safe from command or argument injection. But the following commands transform specific String arguments to Net::IMAP::RawData, which bypasses normal argument validation and encoding and prints the string directly to the socket: #uidsearch, #search, #uidsort, #sort, #uidthread, #thread when criteria is a String, it is sent raw #uidfetch, #fetch when attr is a String, it is sent raw when attr is an Array, each String in attr is sent raw #uidstore, #store…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hm49-wcqc-g2xg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42257 Advisory: net-imap vulnerable to command Injection via "raw" arguments to multiple commands IDs: CVE-2026-42257, GHSA-hm49-wcqc-g2xg Record: https://patchnext.com/advisories/cve-2026-42257 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: net-imap 0.6.4, 0.5.14, 0.4.24. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems net-imap: affected >= 0.6.0, <= 0.6.3; >= 0.5.0, <= 0.5.13; <= 0.4.23; fixed in 0.6.4, 0.5.14, 0.4.24 ## Suggested inspection (read-only) - RubyGems net-imap: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on net-imap. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hm49-wcqc-g2xg (GitHub-reviewed advisory GHSA-hm49-wcqc-g2xg lists affected ranges: RubyGems net-imap >=0.6.0 =0.5.0 =0 <=0.4.23) Commands are suggestions: review each one before running it.
Loading voting…