Budibase auth session cookies are set with httpOnly:false — any XSS can lead to full account takeover
CVE-2026-42239GHSA-4f9j-vr4p-642r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@budibase/backend-core 3.35.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 3.35.10
- Fixed in
- 3.35.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4f9j-vr4p-642r lists affected ranges: npm @budibase/backend-core >=0 <3.35.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4f9j-vr4p-642r lists affected ranges: npm @budibase/backend-core >=0 <3.35.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:N
- EPSS
- CVE-2026-42239: 0.28% estimated exploitation activity in the next 30 days; percentile 20.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The budibase:auth cookie containing the JWT session token is set with httpOnly: false at packages/backend-core/src/utils/utils.ts:218. JavaScript can read this cookie via document.cookie. Given that Budibase has had XSS vulnerabilities (GHSA-gp5x-2v54-v2q5 — stored XSS via unsanitized entity names, published April 2, 2026), this means every XSS becomes a full account takeover — the attacker steals the JWT and has persistent access to the victim's account. The cookie also lacks secure: true (sent over plaintext HTTP) and sameSite attribute. Details packages/backend-core/src/utils/utils.ts, lines 215-226: This function is called for setting the budibase:auth cookie which contains the signed JWT session token. With httpOnly: false, any JavaScript execution context (XSS, injected script, browser extension) can read the token via document.cookie. Missing flags: - httpOnly: false → should be true (prevent JS access) - No secure flag → cookie sent over HTTP (should be secure: true…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4f9j-vr4p-642r
- Revision 1 · created ·
Published from osv record GHSA-4f9j-vr4p-642r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42239 Advisory: Budibase auth session cookies are set with httpOnly:false — any XSS can lead to full account takeover IDs: CVE-2026-42239, GHSA-4f9j-vr4p-642r Record: https://patchnext.com/advisories/cve-2026-42239 (revision 2, source checked 26 Oct 2026, 12:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @budibase/backend-core 3.35.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @budibase/backend-core: affected < 3.35.10; fixed in 3.35.10 ## Suggested inspection (read-only) - `npm ls @budibase/backend-core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @budibase/backend-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4f9j-vr4p-642r (OSV record GHSA-4f9j-vr4p-642r lists affected ranges: npm @budibase/backend-core >=0 <3.35.10 (fixed)) - Verified: https://github.com/advisories/GHSA-4f9j-vr4p-642r (GitHub-reviewed advisory GHSA-4f9j-vr4p-642r lists affected ranges: npm @budibase/backend-core >=0 <3.35.10) Commands are suggestions: review each one before running it.
Loading voting…