Skip to content

← Actionable
Critical, CVSS 9.0

Nginx-UI is Vulnerable to Unauthenticated Remote Code Execution via Backup Restore

CVE-2026-42238GHSA-4pvg-prr3-9cxr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/0xJacky/nginx-ui 2.3.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-42238: 0.97% estimated exploitation activity in the next 30 days; percentile 61.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Product: nginx-ui Repository: 0xJacky/nginx-ui (branch: dev) Vulnerability Class: Authentication Bypass → Arbitrary File Write → OS Command Injection Affected Component: POST /api/restore --- 1. Vulnerability Summary nginx-ui exposes a backup restore endpoint (POST /api/restore) that is completely unauthenticated during the first 10 minutes after process startup on any fresh installation. An unauthenticated remote attacker can upload a crafted backup archive that overwrites the application's configuration file (app.ini) and SQLite database. Because the attacker controls the restored app.ini, they can inject an arbitrary OS command into the TestConfigCmd setting. After the application automatically restarts to apply the restored config, a single follow-up request triggers that command as the user running nginx-ui — typically root in Docker deployments. The 10-minute unauthenticated window resets on every process restart, making this exploitable not only on initial deployments but on…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4pvg-prr3-9cxr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42238

Advisory: Nginx-UI is Vulnerable to Unauthenticated Remote Code Execution via Backup Restore
IDs: CVE-2026-42238, GHSA-4pvg-prr3-9cxr
Record: https://patchnext.com/advisories/cve-2026-42238 (revision 1, source checked 26 Oct 2026, 15:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/0xJacky/nginx-ui 2.3.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/0xJacky/nginx-ui: affected < 2.3.8; fixed in 2.3.8

## Suggested inspection (read-only)
- Go github.com/0xJacky/nginx-ui: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/0xJacky/nginx-ui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4pvg-prr3-9cxr (GitHub-reviewed advisory GHSA-4pvg-prr3-9cxr lists affected ranges: Go github.com/0xJacky/nginx-ui >=0 <2.3.8)

Commands are suggestions: review each one before running it.

Loading voting…