n8n Vulnerable to XSS via MCP OAuth client
CVE-2026-42235GHSA-537j-gqpc-p7fq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.18.1, 2.17.4, 1.123.32), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- < 1.123.32>= 2.18.0, < 2.18.1>= 2.17.0, < 2.17.4
- Fixed in
- 1.123.32, 2.17.4, 2.18.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-537j-gqpc-p7fq lists affected ranges: npm n8n >=0 =2.18.0 =2.17.0 <2.17.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-537j-gqpc-p7fq lists affected ranges: npm n8n >=0 =2.18.0 =2.17.0 <2.17.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.8 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L · score source
- EPSS
- CVE-2026-42235: 0.33% estimated exploitation activity in the next 30 days; percentile 26.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An unauthenticated attacker could register a malicious MCP OAuth client with a crafted clientname. If a victim user authorized the OAuth consent dialog and a second user subsequently revoked that access, a toast notification would render the injected script. Clicking the link would execute arbitrary JavaScript in the victim's authenticated n8n browser session, enabling credential and session token theft, workflow manipulation, or privilege escalation. Patches This issue has been fixed in n8n version 2.14.2. Users should upgrade to this version or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict access to the n8n instance and the MCP OAuth registration endpoint to trusted users only. - Disable MCP server functionality if it is not actively required. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-537j-gqpc-p7fq
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-537j-gqpc-p7fq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42235 Advisory: n8n Vulnerable to XSS via MCP OAuth client IDs: CVE-2026-42235, GHSA-537j-gqpc-p7fq Record: https://patchnext.com/advisories/cve-2026-42235 (revision 3, source checked 26 Oct 2026, 12:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 2.18.1, 2.17.4, 1.123.32. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected < 1.123.32; >= 2.18.0, < 2.18.1; >= 2.17.0, < 2.17.4; fixed in 1.123.32, 2.17.4, 2.18.1 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-537j-gqpc-p7fq (OSV record GHSA-537j-gqpc-p7fq lists affected ranges: npm n8n >=0 =2.18.0 =2.17.0 <2.17.4 (fixed)) - Verified: https://github.com/advisories/GHSA-537j-gqpc-p7fq (GitHub-reviewed advisory GHSA-537j-gqpc-p7fq lists affected ranges: npm n8n >=0 =2.18.0 =2.17.0 <2.17.4) Commands are suggestions: review each one before running it.
Loading voting…