Skip to content

← Actionable
Medium, CVSS 5.1amended

n8n has Open Redirect in MCP OAuth Consent Flow

CVE-2026-42230GHSA-f6x8-65q6-j9m9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.18.1, 2.17.4, 1.123.32), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    < 1.123.32>= 2.18.0, < 2.18.1>= 2.0.0, < 2.17.4
    Fixed in
    1.123.32, 2.17.4, 2.18.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N · score source
EPSS
  • CVE-2026-42230: 0.18% estimated exploitation activity in the next 30 days; percentile 7.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The /mcp-oauth/register endpoint accepted OAuth client registrations without authentication, allowing arbitrary redirecturi values to be registered. When a user denies the MCP OAuth consent dialog, the handleDeny handler redirects the user to the registered redirecturi without validation, enabling an open redirect to an attacker-controlled URL. An attacker can craft a phishing link and send it to a victim; if the victim clicks "Deny" on the consent page, they are silently redirected to an external site. Patches The issue has been fixed in n8n versions 1.123.32, 2.17.4, and 2.18.1. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict network access to the n8n instance to prevent untrusted users from reaching the MCP OAuth endpoints. - Limit access to the n8n instance to fully trusted users only. These workarounds…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-f6x8-65q6-j9m9

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-f6x8-65q6-j9m9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42230

Advisory: n8n has Open Redirect in MCP OAuth Consent Flow
IDs: CVE-2026-42230, GHSA-f6x8-65q6-j9m9
Record: https://patchnext.com/advisories/cve-2026-42230 (revision 3, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 2.18.1, 2.17.4, 1.123.32. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected < 1.123.32; >= 2.18.0, < 2.18.1; >= 2.0.0, < 2.17.4; fixed in 1.123.32, 2.17.4, 2.18.1

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f6x8-65q6-j9m9 (OSV record GHSA-f6x8-65q6-j9m9 lists affected ranges: npm n8n >=0 =2.18.0 =2.0.0 <2.17.4 (fixed))
- Verified: https://github.com/advisories/GHSA-f6x8-65q6-j9m9 (GitHub-reviewed advisory GHSA-f6x8-65q6-j9m9 lists affected ranges: npm n8n >=0 =2.18.0 =2.0.0 <2.17.4)

Commands are suggestions: review each one before running it.

Loading voting…