Skip to content

← Actionable
Medium, CVSS 6.0amended

n8n has Public API Variables IDOR that Allows Cross-Project Secret Disclosure

CVE-2026-42227GHSA-756q-gq9h-fp22

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.18.1, 2.17.4, 1.123.32), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    < 1.123.32>= 2.18.0, < 2.18.1>= 2.0.0, < 2.17.4
    Fixed in
    1.123.32, 2.17.4, 2.18.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-42227: 0.20% estimated exploitation activity in the next 30 days; percentile 10.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An authenticated user with a valid API key scoped to variable:list could read variables from projects they are not a member of by supplying an arbitrary projectId query parameter to the public API variables endpoint. The handler queried the variables repository directly without enforcing project membership checks, bypassing the authorization-aware service layer used by the internal enterprise controller. If variables were misused to store sensitive information such as credentials or tokens, they should be rotated immediately. This issue only affects licensed enterprise or team deployments with multiple projects and the variables feature enabled. Patches The issue has been fixed in n8n versions 1.123.32, 2.17.4, and 2.18.1. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict n8n access and API key issuance to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-756q-gq9h-fp22

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-756q-gq9h-fp22

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42227

Advisory: n8n has Public API Variables IDOR that Allows Cross-Project Secret Disclosure
IDs: CVE-2026-42227, GHSA-756q-gq9h-fp22
Record: https://patchnext.com/advisories/cve-2026-42227 (revision 3, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 2.18.1, 2.17.4, 1.123.32. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected < 1.123.32; >= 2.18.0, < 2.18.1; >= 2.0.0, < 2.17.4; fixed in 1.123.32, 2.17.4, 2.18.1

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-756q-gq9h-fp22 (OSV record GHSA-756q-gq9h-fp22 lists affected ranges: npm n8n >=0 =2.18.0 =2.0.0 <2.17.4 (fixed))
- Verified: https://github.com/advisories/GHSA-756q-gq9h-fp22 (GitHub-reviewed advisory GHSA-756q-gq9h-fp22 lists affected ranges: npm n8n >=0 =2.18.0 =2.0.0 <2.17.4)

Commands are suggestions: review each one before running it.

Loading voting…