Skip to content

← Actionable
Medium, CVSS 6.5

Nginx-UI Settings API Exposes Protected Secrets

CVE-2026-42223GHSA-q4w7-56hr-83rm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/0xJacky/nginx-ui 2.3.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-42223: 0.29% estimated exploitation activity in the next 30 days; percentile 22.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The GetSettings API handler (api/settings/settings.go:24-65) serializes all settings structs to JSON and returns them to authenticated users. Many sensitive fields are tagged with protected:"true" - however, this tag is only enforced during writes (via ProtectedFill in SaveSettings) and is completely ignored during reads. This exposes 40+ protected fields including JwtSecret (enabling auth token forgery), NodeSecret (enabling cluster node impersonation), OIDC ClientSecret (enabling OAuth account takeover), and the IP whitelist configuration. Details Vulnerable Code api/settings/settings.go:49-64 - GetSettings serializes all fields Go's json.Marshal serializes all exported fields with json: tags. The protected:"true" struct tag is a custom tag - it has no effect on JSON serialization. Protection is Write-Only api/settings/settings.go:126-135 - ProtectedFill only used during saves ProtectedFill prevents overwriting protected fields during SaveSettings, but GetSettings has no…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q4w7-56hr-83rm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42223

Advisory: Nginx-UI Settings API Exposes Protected Secrets
IDs: CVE-2026-42223, GHSA-q4w7-56hr-83rm
Record: https://patchnext.com/advisories/cve-2026-42223 (revision 1, source checked 26 Oct 2026, 15:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/0xJacky/nginx-ui 2.3.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/0xJacky/nginx-ui: affected <= 2.3.7; fixed in 2.3.8

## Suggested inspection (read-only)
- Go github.com/0xJacky/nginx-ui: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/0xJacky/nginx-ui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q4w7-56hr-83rm (GitHub-reviewed advisory GHSA-q4w7-56hr-83rm lists affected ranges: Go github.com/0xJacky/nginx-ui >=0 <=2.3.7)

Commands are suggestions: review each one before running it.

Loading voting…