React Router's vendored turbo-stream v2 allows arbitrary constructor invocation via TYPE_ERROR deserialization leading to Unauth RCE
CVE-2026-42211GHSA-49rj-9fvp-4h2h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (react-router 7.14.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm react-router
- Affected
- >= 7.0.0, <= 7.14.1
- Fixed in
- 7.14.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-49rj-9fvp-4h2h lists affected ranges: npm react-router >=7.0.0 <7.14.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-49rj-9fvp-4h2h lists affected ranges: npm react-router >=7.0.0 <=7.14.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-42211: 0.42% estimated exploitation activity in the next 30 days; percentile 35.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When using React Router v7 in Framework Mode, there exists a combination of steps that could potentially allow unauthorized RCE through external requests. This first requires the application code to have an existing prototype pollution vulnerability. This can be leveraged into a 2-step attack in which the second step can trigger unauthorized RCE on the remote server. [!NOTE] This does not impact your React Router application if you are using Declarative Mode (<BrowserRouter) or Data Mode (createBrowserRouter/<RouterProvider).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-49rj-9fvp-4h2h
- Revision 1 · created ·
Published from osv record GHSA-49rj-9fvp-4h2h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42211 Advisory: React Router's vendored turbo-stream v2 allows arbitrary constructor invocation via TYPE_ERROR deserialization leading to Unauth RCE IDs: CVE-2026-42211, GHSA-49rj-9fvp-4h2h Record: https://patchnext.com/advisories/cve-2026-42211 (revision 2, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: react-router 7.14.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm react-router: affected >= 7.0.0, <= 7.14.1; fixed in 7.14.2 ## Suggested inspection (read-only) - `npm ls react-router --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on react-router. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-49rj-9fvp-4h2h (OSV record GHSA-49rj-9fvp-4h2h lists affected ranges: npm react-router >=7.0.0 <7.14.2 (fixed)) - Verified: https://github.com/advisories/GHSA-49rj-9fvp-4h2h (GitHub-reviewed advisory GHSA-49rj-9fvp-4h2h lists affected ranges: npm react-router >=7.0.0 <=7.14.1) Commands are suggestions: review each one before running it.
Loading voting…