LiteLLM has SQL Injection in Proxy API key verification
CVE-2026-42208GHSA-r75f-5x8p-qvmc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (litellm 1.83.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI litellm
- Affected
- >= 1.81.16, < 1.83.7
- Fixed in
- 1.83.7
Sources
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2026-42208 to the Known Exploited Vulnerabilities catalog on 2026-05-08.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2026-05-08).
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r75f-5x8p-qvmc lists affected ranges: PyPI litellm >=1.81.16 <1.83.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r75f-5x8p-qvmc lists affected ranges: PyPI litellm >=1.81.16 <1.83.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-42208: 89.42% estimated exploitation activity in the next 30 days; percentile 99.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A database query used during proxy API key checks mixed the caller-supplied key value into the query text instead of passing it as a separate parameter. An unauthenticated attacker could send a specially crafted Authorization header to any LLM API route (for example POST /chat/completions) and reach this query through the proxy's error-handling path. An attacker could read data from the proxy's database and may be able to modify it, leading to unauthorised access to the proxy and the credentials it manages. Patches Fixed in 1.83.7. The caller-supplied value is now always passed to the database as a separate parameter. Upgrade to 1.83.7 or later. Workarounds If upgrading is not immediately possible, set disableerrorlogs: true under generalsettings. This removes the path through which unauthenticated input reaches the vulnerable query. References - Patched release: v1.83.7-stable Discovery Credit: Tencent YunDing Security Lab
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-r75f-5x8p-qvmc
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-r75f-5x8p-qvmc
- Revision 1 · created ·
Published from ghsa record GHSA-r75f-5x8p-qvmc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42208 Advisory: LiteLLM has SQL Injection in Proxy API key verification IDs: CVE-2026-42208, GHSA-r75f-5x8p-qvmc Record: https://patchnext.com/advisories/cve-2026-42208 (revision 4, source checked 26 Oct 2026, 13:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: litellm 1.83.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI litellm: affected >= 1.81.16, < 1.83.7; fixed in 1.83.7 ## Suggested inspection (read-only) - `python -m pip show litellm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on litellm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2026-42208 to the Known Exploited Vulnerabilities catalog on 2026-05-08.) - Verified: https://github.com/advisories/GHSA-r75f-5x8p-qvmc (GitHub-reviewed advisory GHSA-r75f-5x8p-qvmc lists affected ranges: PyPI litellm >=1.81.16 <1.83.7) - Verified: https://osv.dev/vulnerability/GHSA-r75f-5x8p-qvmc (OSV record GHSA-r75f-5x8p-qvmc lists affected ranges: PyPI litellm >=1.81.16 <1.83.7 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…