Skip to content

← Actionable
Medium, CVSS 6.1

Magento LTS Vulnerable to Open Redirect via Unvalidated uenc Parameter in stockAction()

CVE-2026-42207GHSA-qpgq-5g92-j5q8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openmage/magento-lts 20.18.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-42207: 0.18% estimated exploitation activity in the next 30 days; percentile 7.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary MageProductAlertAddController::stockAction() reads the uenc query parameter and passes it directly to $this-redirectUrl($backUrl) without calling $this-isUrlInternal() When the supplied productid does not match any catalog product, the server issues an unvalidated HTTP 302 redirect to whatever URL was provided as uenc. Vulnerable path: Secure peer (priceAction()): Steps to Reproduce Prerequisites - OpenMage LTS ≤ 20.16.0 with Product Alerts enabled (default configuration) - A valid, logged-in customer session on the target store Step 1 – Authenticate as a Customer (Attacker controls the crafted link; victim must be logged in) The preDispatch() hook calls Mage::getSingleton('customer/session')-authenticate($this). If the request comes from an unauthenticated user, they are redirected to the login page first. The open redirect only fires after the customer is authenticated. This is the realistic attack scenario: the attacker sends a crafted link to a customer who is already…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qpgq-5g92-j5q8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42207

Advisory: Magento LTS Vulnerable to Open Redirect via Unvalidated `uenc` Parameter in `stockAction()`
IDs: CVE-2026-42207, GHSA-qpgq-5g92-j5q8
Record: https://patchnext.com/advisories/cve-2026-42207 (revision 1, source checked 26 Oct 2026, 14:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openmage/magento-lts 20.18.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist openmage/magento-lts: affected <= 20.17.0; fixed in 20.18.0

## Suggested inspection (read-only)
- Packagist openmage/magento-lts: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openmage/magento-lts.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qpgq-5g92-j5q8 (GitHub-reviewed advisory GHSA-qpgq-5g92-j5q8 lists affected ranges: Packagist openmage/magento-lts >=0 <=20.17.0)

Commands are suggestions: review each one before running it.

Loading voting…