LiteLLM: Server-Side Template Injection in /prompts/test endpoint
CVE-2026-42203GHSA-xqmj-j6mv-4862
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (litellm 1.83.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI litellm
- Affected
- >= 1.80.5, < 1.83.7
- Fixed in
- 1.83.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xqmj-j6mv-4862 lists affected ranges: PyPI litellm >=1.80.5 <1.83.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xqmj-j6mv-4862 lists affected ranges: PyPI litellm >=1.80.5 <1.83.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-42203: 0.37% estimated exploitation activity in the next 30 days; percentile 31.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The POST /prompts/test endpoint accepted user-supplied prompt templates and rendered them without sandboxing. A crafted template could run arbitrary code inside the LiteLLM Proxy process. The endpoint only checks that the caller presents a valid proxy API key, so any authenticated user could reach it. Depending on how the proxy is deployed, this could expose secrets in the process environment (such as provider API keys or database credentials) and allow commands to be run on the host. Proxy deployments running an affected version are in scope. Patches The issue is fixed in 1.83.7-stable. The fix switches the prompt template renderer to a sandboxed environment that blocks the attributes this attack relies on. LiteLLM recommends upgrading to 1.83.7-stable or later. Workarounds If upgrading is not immediately possible: 1. Block POST /prompts/test at your reverse proxy or API gateway. 2. Review and rotate API keys that should not have access to prompt management routes.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-xqmj-j6mv-4862
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-xqmj-j6mv-4862
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42203 Advisory: LiteLLM: Server-Side Template Injection in /prompts/test endpoint IDs: CVE-2026-42203, GHSA-xqmj-j6mv-4862 Record: https://patchnext.com/advisories/cve-2026-42203 (revision 3, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: litellm 1.83.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI litellm: affected >= 1.80.5, < 1.83.7; fixed in 1.83.7 ## Suggested inspection (read-only) - `python -m pip show litellm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on litellm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xqmj-j6mv-4862 (OSV record GHSA-xqmj-j6mv-4862 lists affected ranges: PyPI litellm >=1.80.5 <1.83.7 (fixed)) - Verified: https://github.com/advisories/GHSA-xqmj-j6mv-4862 (GitHub-reviewed advisory GHSA-xqmj-j6mv-4862 lists affected ranges: PyPI litellm >=1.80.5 <1.83.7) Commands are suggestions: review each one before running it.
Loading voting…