pgjdbc: Unbounded PBKDF2 iterations in SCRAM authentication allows CPU exhaustion DoS
CVE-2026-42198GHSA-98qh-xjc8-98pq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.postgresql:postgresql 42.7.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.postgresql:postgresql
- Affected
- >= 42.2.0, < 42.7.11
- Fixed in
- 42.7.11
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-98qh-xjc8-98pq lists affected ranges: Maven org.postgresql:postgresql >=42.2.0 <42.7.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-42198: 3.26% estimated exploitation activity in the next 30 days; percentile 88.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary pgjdbc is vulnerable to a client-side denial of service during SCRAM-SHA-256 authentication. Impact A malicious server can instruct the driver to perform SCRAM authentication with a very large iteration count. With a large enough value, the client spends an unbounded amount of CPU time inside PBKDF2 before authentication can fail. A single attempt ties up a CPU core. Repeated or concurrent attempts exhaust client CPU and can wedge connection pools. In affected versions, loginTimeout did not fully mitigate this problem. When loginTimeout expired, the caller could stop waiting, but the worker thread performing the connection attempt could continue running and burning CPU inside the SCRAM PBKDF2 computation. This issue affects availability. It does not provide authentication bypass, privilege escalation, or direct password disclosure. A user is vulnerable when all of the following are true: 1. The connection uses SCRAM-SHA-256 authentication. 2. The client reaches a malicious,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-98qh-xjc8-98pq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42198 Advisory: pgjdbc: Unbounded PBKDF2 iterations in SCRAM authentication allows CPU exhaustion DoS IDs: CVE-2026-42198, GHSA-98qh-xjc8-98pq Record: https://patchnext.com/advisories/cve-2026-42198 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.postgresql:postgresql 42.7.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.postgresql:postgresql: affected >= 42.2.0, < 42.7.11; fixed in 42.7.11 ## Suggested inspection (read-only) - Maven org.postgresql:postgresql: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.postgresql:postgresql. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-98qh-xjc8-98pq (GitHub-reviewed advisory GHSA-98qh-xjc8-98pq lists affected ranges: Maven org.postgresql:postgresql >=42.2.0 <42.7.11) Commands are suggestions: review each one before running it.
Loading voting…