Skip to content

← Actionable
Critical, CVSS 9.9amended

django-s3file is vulnerable to relative path traversal

CVE-2026-42196GHSA-67qg-7284-2277

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (django-s3file 7.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N · score source
EPSS
  • CVE-2026-42196: 0.56% estimated exploitation activity in the next 30 days; percentile 46.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact `S3FileMiddleware` is vulnerable to relative path traversal attacks, where an attacker can use a modified request to escape pre-signed upload locations and have the Django application load files from random locations into `request.FILES` Depending on how files are handled, this may lead to confidentiality and integrity issues.

Patches Django-S3File urges all users to update to a patched version >=7.0.2.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 6 · amended ·

    Amended from osv record GHSA-67qg-7284-2277

  2. Revision 5 · amended ·

    Amended from ghsa record GHSA-67qg-7284-2277

  3. Revision 4 · amended ·

    Amended from ghsa record GHSA-67qg-7284-2277

  4. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  5. Revision 2 · amended ·

    Amended from osv record GHSA-67qg-7284-2277

  6. Revision 1 · created ·

    Published from ghsa record GHSA-67qg-7284-2277

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42196

Advisory: django-s3file is vulnerable to relative path traversal
IDs: CVE-2026-42196, GHSA-67qg-7284-2277
Record: https://patchnext.com/advisories/cve-2026-42196 (revision 6, source checked 28 Oct 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: django-s3file 7.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI django-s3file: affected < 7.0.2; fixed in 7.0.2

## Suggested inspection (read-only)
- `python -m pip show django-s3file`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on django-s3file.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-67qg-7284-2277 (GitHub-reviewed advisory GHSA-67qg-7284-2277 lists affected ranges: PyPI django-s3file >=0 <=7.0.1)
- Verified: https://osv.dev/vulnerability/GHSA-67qg-7284-2277 (OSV record GHSA-67qg-7284-2277 lists affected ranges: PyPI django-s3file >=0 <7.0.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…