russh has pre-auth DoS via unbounded allocation in its keyboard-interactive auth handler
CVE-2026-42189GHSA-f5v4-2wr6-hqmg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (russh 0.60.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io russh
- Affected
- < 0.60.1
- Fixed in
- 0.60.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f5v4-2wr6-hqmg lists affected ranges: crates.io russh >=0 <0.60.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-42189: 0.48% estimated exploitation activity in the next 30 days; percentile 41.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A pre-authentication denial-of-service vulnerability exists in the server's keyboard-interactive authentication handler. A malicious client can crash any russh-based server that implements keyboard-interactive auth (e.g., for 2FA/TOTP) with a single malformed packet, requiring no credentials. Vulnerability Details In russh/src/server/encrypted.rs, the function readuserauthinforesponse decodes a u32 count from the client's SSHMSGUSERAUTHINFORESPONSE and passes it directly to Vec::withcapacity(): An attacker can send n = 0x10000000 (268M) or larger in a minimal packet (~50 bytes after encryption). The server attempts to allocate n ~24 bytes (size of Option<Bytes) = ~6.4GB, causing an OOM crash. Attack Flow 1. Attacker connects via TCP, completes key exchange (no credentials needed -- this is the anonymous DH handshake, not authentication) 2. Sends USERAUTHREQUEST with method keyboard-interactive 3. Server handler returns Auth::Partial with prompts (standard for 2FA/TOTP) 4.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f5v4-2wr6-hqmg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42189 Advisory: russh has pre-auth DoS via unbounded allocation in its keyboard-interactive auth handler IDs: CVE-2026-42189, GHSA-f5v4-2wr6-hqmg Record: https://patchnext.com/advisories/cve-2026-42189 (revision 1, source checked 26 Oct 2026, 15:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: russh 0.60.1. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io russh: affected < 0.60.1; fixed in 0.60.1 ## Suggested inspection (read-only) - crates.io russh: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on russh. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f5v4-2wr6-hqmg (GitHub-reviewed advisory GHSA-f5v4-2wr6-hqmg lists affected ranges: crates.io russh >=0 <0.60.1) Commands are suggestions: review each one before running it.
Loading voting…