Skip to content

← Actionable
Medium, CVSS 6.5

Lemmy has SSRF and internal image disclosure in post link metadata via unvalidated og:image

CVE-2026-42181GHSA-h6hf-9846-xwrq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lemmy_api_common 0.19.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-42181: 0.26% estimated exploitation activity in the next 30 days; percentile 18.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Lemmy fetches metadata for user-supplied post URLs and, under the default StoreLinkPreviews image mode, downloads the preview image through local pict-rs. While the top-level page URL is checked against internal IP ranges, the extracted og:image URL is not subject to the same restriction. As a result, an authenticated low-privileged user can submit an attacker-controlled public page whose Open Graph image points to an internal image endpoint. Lemmy will fetch that internal image server-side and store a local thumbnail that can then be served back to users. Details The metadata fetch logic applies an internal-address check only to the initial post URL. After HTML parsing, extractopengraphdata() accepts absolute og:image values and returns them as-is. Later, generatepostlinkmetadata() passes that second-hop image URL into generatepictrsthumbnail(), which instructs local pict-rs to fetch it through image/download?url=.... This creates a two-stage source-to-sink chain where the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h6hf-9846-xwrq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42181

Advisory: Lemmy has SSRF and internal image disclosure in post link metadata via unvalidated og:image
IDs: CVE-2026-42181, GHSA-h6hf-9846-xwrq
Record: https://patchnext.com/advisories/cve-2026-42181 (revision 1, source checked 26 Oct 2026, 15:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lemmy_api_common 0.19.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io lemmy_api_common: affected < 0.19.18; fixed in 0.19.18

## Suggested inspection (read-only)
- crates.io lemmy_api_common: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lemmy_api_common.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h6hf-9846-xwrq (GitHub-reviewed advisory GHSA-h6hf-9846-xwrq lists affected ranges: crates.io lemmy_api_common >=0 <0.19.18)

Commands are suggestions: review each one before running it.

Loading voting…