Lemmy has SSRF in /api/v3/post via Webmention dispatch
CVE-2026-42180GHSA-3jvj-v6w2-h948
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (lemmy_api_common 0.19.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io lemmy_api_common
- Affected
- < 0.19.18
- Fixed in
- 0.19.18
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3jvj-v6w2-h948 lists affected ranges: crates.io lemmy_api_common >=0 <0.19.18
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2026-42180: 0.18% estimated exploitation activity in the next 30 days; percentile 8.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Lemmy allows an authenticated low-privileged user to create a link post through POST /api/v3/post. When a post is created in a public community, the backend asynchronously sends a Webmention to the attacker-controlled link target. The submitted URL is checked for syntax and scheme, but the audited code path does not reject loopback, private, or link-local destinations before the Webmention request is issued. This lets a normal user trigger server-side HTTP requests toward internal services. Details The entry point is the normal post creation API. The user-controlled url field is accepted, normalized with dieselurlcreate(), and only validated with isvalidurl(). That validation allows http and https but does not implement internal address rejection. The post creation flow then schedules Webmention delivery for public communities. This creates a direct source-to-sink path from an externally supplied post URL to a server-side outbound HTTP request. Core vulnerable code path:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3jvj-v6w2-h948
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42180 Advisory: Lemmy has SSRF in /api/v3/post via Webmention dispatch IDs: CVE-2026-42180, GHSA-3jvj-v6w2-h948 Record: https://patchnext.com/advisories/cve-2026-42180 (revision 1, source checked 26 Oct 2026, 15:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: lemmy_api_common 0.19.18. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io lemmy_api_common: affected < 0.19.18; fixed in 0.19.18 ## Suggested inspection (read-only) - crates.io lemmy_api_common: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lemmy_api_common. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3jvj-v6w2-h948 (GitHub-reviewed advisory GHSA-3jvj-v6w2-h948 lists affected ranges: crates.io lemmy_api_common >=0 <0.19.18) Commands are suggestions: review each one before running it.
Loading voting…