Skip to content

← Actionable
Medium, CVSS 6.5amended

requests-hardened is Vulnerable to Server-Side Request Forgery

CVE-2026-42175GHSA-vh75-fwv3-pqrh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (requests-hardened 1.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N
EPSS
  • CVE-2026-42175: 0.30% estimated exploitation activity in the next 30 days; percentile 23.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The SSRF protection in requests-hardened prior to version 1.2.1 fails to block IP addresses within the RFC 6598 Shared Address Space (100.64.0.0/10). An attacker who can supply arbitrary URLs to requests-hardened could exploit this gap to access internal services hosted within 100.64.0.0/10. This is for example relevant in environments such as AWS EKS where 100.64.0.0/10 is commonly used as the default pod CIDR. The impact is environment-dependent, deployments that utilize the affected CIDR range for internal networking are exposed to SSRF bypass, while others may not be affected. The issue is resolved in version 1.2.1 by extending the IP filtering logic to explicitly block the RFC 6598 range in addition to standard private addresses, as well as blocking all other reserved addresses (such as multicast) to prevent the re-occurrence of similar issues. Version 1.2.1 is now blocking the following CIDRs: - 192.88.99.0/24 - 6to4 relay anycast - 100.64.0.0/10 - CG-NAT - 5f00::/16 - IPv6…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vh75-fwv3-pqrh

  2. Revision 1 · created ·

    Published from osv record GHSA-vh75-fwv3-pqrh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42175

Advisory: requests-hardened is Vulnerable to Server-Side Request Forgery
IDs: CVE-2026-42175, GHSA-vh75-fwv3-pqrh
Record: https://patchnext.com/advisories/cve-2026-42175 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: requests-hardened 1.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI requests-hardened: affected < 1.2.1; fixed in 1.2.1

## Suggested inspection (read-only)
- `python -m pip show requests-hardened`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on requests-hardened.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vh75-fwv3-pqrh (OSV record GHSA-vh75-fwv3-pqrh lists affected ranges: PyPI requests-hardened >=0 <1.2.1 (fixed))
- Verified: https://github.com/advisories/GHSA-vh75-fwv3-pqrh (GitHub-reviewed advisory GHSA-vh75-fwv3-pqrh lists affected ranges: PyPI requests-hardened >=0 <1.2.1)

Commands are suggestions: review each one before running it.

Loading voting…