Magento LTS has Weak API Session ID — Predictable MD5 of Time-Derived Inputs
CVE-2026-42155GHSA-2cwr-gcf9-pvxr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openmage/magento-lts 20.18.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist openmage/magento-lts
- Affected
- <= 20.17.0
- Fixed in
- 20.18.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2cwr-gcf9-pvxr lists affected ranges: Packagist openmage/magento-lts >=0 <=20.17.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-42155: 0.37% estimated exploitation activity in the next 30 days; percentile 30.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected Version: OpenMage LTS ≤ 20.16.0 (confirmed on 20.16.0) Affected File: https://github.com/OpenMage/magento-lts/blob/main/app/code/core/Mage/Api/Model/Session.php – start() method Summary The XML-RPC / SOAP API session ID is generated using an outdated, time-based construction rather than a Cryptographically Secure Pseudo-Random Number Generator (CSPRNG): All inputs to the MD5 hash are time-derived and non-secure: | Input | Value | Predictability | |----------------------------|---------------------------------------------------|----------------------------------------| | time() | Unix timestamp (seconds) | Fully predictable | | uniqid('', true) prefix | sprintf('%08x%05x', $sec, $usec/10) | Highly predictable via network timing | | uniqid('', true) suffix | phpcombinedlcg() decimal float | Process-state dependent (getpid() ^ time()) | | $sessionName | null (empty) — called without arg | Constant | Because the resulting digest relies entirely on the timestamp and the PHP…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2cwr-gcf9-pvxr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42155 Advisory: Magento LTS has Weak API Session ID — Predictable MD5 of Time-Derived Inputs IDs: CVE-2026-42155, GHSA-2cwr-gcf9-pvxr Record: https://patchnext.com/advisories/cve-2026-42155 (revision 1, source checked 26 Oct 2026, 14:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openmage/magento-lts 20.18.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist openmage/magento-lts: affected <= 20.17.0; fixed in 20.18.0 ## Suggested inspection (read-only) - Packagist openmage/magento-lts: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openmage/magento-lts. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2cwr-gcf9-pvxr (GitHub-reviewed advisory GHSA-2cwr-gcf9-pvxr lists affected ranges: Packagist openmage/magento-lts >=0 <=20.17.0) Commands are suggestions: review each one before running it.
Loading voting…