Skip to content

← Actionable
Critical, CVSS 9.6amended

OpenC3 COSMOS has SQL Injection in QuestDB Time-Series Database

CVE-2026-42087GHSA-v529-vhwc-wfc5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openc3 7.0.0; openc3 7.0.0-rc3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI openc3

    Affected
    >= 6.7.0, < 7.0.0
    Fixed in
    7.0.0
  • RubyGems openc3

    Affected
    >= 6.7.0, < 7.0.0-rc3
    Fixed in
    7.0.0-rc3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-42087: 0.32% estimated exploitation activity in the next 30 days; percentile 25.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerability Type: CWE-89: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') Attack type: Authenticated remote Impact: Telemetry data disclosure and deletion Affected components: openc3-tsdb (QuestDB) A SQL injection vulnerability exists in the Time-Series Database (TSDB) component of COSMOS. The tsdblookup function in the cvtmodel.rb file directly places user-supplied input into a SQL query without sanitizing the input. As a result, a user can break out of the initial SQL statement and execute arbitrary SQL commands, including deleting data. <img width="940" height="719" alt="image" src="https://github.com/user-attachments/assets/2c2dd294-6192-49d3-b670-fd7b82c05be0" / Figure 1: Source code vulnerable to SQL injection Additionally, the gettlmvalues RPC endpoint only requires “tlm” permissions, allowing any user with the Admin, Operator, Viewer, or Runner roles to send a request to the TSDB. This permission is defined in roles-permissions.md to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v529-vhwc-wfc5

  2. Revision 1 · created ·

    Published from osv record PYSEC-2026-2244

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42087

Advisory: OpenC3 COSMOS has SQL Injection in QuestDB Time-Series Database
IDs: CVE-2026-42087, GHSA-v529-vhwc-wfc5
Record: https://patchnext.com/advisories/cve-2026-42087 (revision 2, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openc3 7.0.0; openc3 7.0.0-rc3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI openc3: affected >= 6.7.0, < 7.0.0; fixed in 7.0.0
- RubyGems openc3: affected >= 6.7.0, < 7.0.0-rc3; fixed in 7.0.0-rc3

## Suggested inspection (read-only)
- `python -m pip show openc3`: prints the installed version. Run with the environment that serves production active.
- RubyGems openc3: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openc3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/PYSEC-2026-2244 (OSV record PYSEC-2026-2244 lists affected ranges: PyPI openc3 >=6.7.0 <7.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-v529-vhwc-wfc5 (GitHub-reviewed advisory GHSA-v529-vhwc-wfc5 lists affected ranges: RubyGems openc3 >=6.7.0 <7.0.0-rc3)

Commands are suggestions: review each one before running it.

Loading voting…