Skip to content

← Actionable
High, CVSS 8.1amended

OpenC3 COSMOS: Hijacked session token can be used to reset password for persistence

CVE-2026-42084GHSA-wgx6-g857-jjf7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openc3 6.10.5; openc3 7.0.0-rc3, 6.10.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI openc3

    Affected
    < 6.10.5
    Fixed in
    6.10.5
  • RubyGems openc3

    Affected
    < 6.10.5>= 7.0.0.pre.rc1, < 7.0.0-rc3
    Fixed in
    6.10.5, 7.0.0-rc3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-42084: 0.30% estimated exploitation activity in the next 30 days; percentile 23.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The OpenC3 password change functionality allows a user to change their password without providing the old password, by accepting a valid session token instead. In assumed breach scenarios, this behaviour can be exploited by an attacker who has already obtained a valid session token, to gain persistence in hijacked account (including admin) and prevent legitimate users from accessing the account. Details The design flaw in authentication model (authentication.rb) allows for interchangeable use of password and session tokens for user authentication As old tokens are not revoked upon password reset, an attacker who has obtained a valid session token can continue to authenticate and change the account’s password even after the victim resets it, thereby maintaining persistent control over the compromised account. PoC 1. Attacker is logged in user account with hijacked valid session token, but not knowing the actual password 2. Legitimate user, as preventive action, changes his…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wgx6-g857-jjf7

  2. Revision 1 · created ·

    Published from osv record PYSEC-2026-2242

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42084

Advisory: OpenC3 COSMOS: Hijacked session token can be used to reset password for persistence
IDs: CVE-2026-42084, GHSA-wgx6-g857-jjf7
Record: https://patchnext.com/advisories/cve-2026-42084 (revision 2, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openc3 6.10.5; openc3 7.0.0-rc3, 6.10.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI openc3: affected < 6.10.5; fixed in 6.10.5
- RubyGems openc3: affected < 6.10.5; >= 7.0.0.pre.rc1, < 7.0.0-rc3; fixed in 6.10.5, 7.0.0-rc3

## Suggested inspection (read-only)
- `python -m pip show openc3`: prints the installed version. Run with the environment that serves production active.
- RubyGems openc3: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openc3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/PYSEC-2026-2242 (OSV record PYSEC-2026-2242 lists affected ranges: PyPI openc3 >=0 <6.10.5 (fixed))
- Verified: https://github.com/advisories/GHSA-wgx6-g857-jjf7 (GitHub-reviewed advisory GHSA-wgx6-g857-jjf7 lists affected ranges: RubyGems openc3 >=0 =7.0.0.pre.rc1 <7.0.0-rc3)

Commands are suggestions: review each one before running it.

Loading voting…