Skip to content

← Actionable
High, CVSS 8.6amended

PPTAgent: Arbitrary Code Execution via Python eval() of LLM-Generated Code with Builtins in Scope

CVE-2026-42079GHSA-89g2-xw5c-v95p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pptagent 1.1.36), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pptagent

    Affected
    < 1.1.36
    Fixed in
    1.1.36

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-42079: 0.14% estimated exploitation activity in the next 30 days; percentile 3.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary This vulnerability has been fixed in https://github.com/icip-cas/PPTAgent/commit/418491a9a1c02d9d93194b5973bb58df35cf9d00. CodeExecutor.executeactions (pptagent/apis.py:126-205) processes LLM-generated slide editing actions using Python's eval(): The call eval(line, {}, {func: partialfunc}) passes an empty dict as globals. Per Python's language reference: "If the globals dictionary is present and does not contain a value for the key builtins, a reference to the dictionary of the built-in module builtins is inserted under that key before the expression is parsed." This means import, open, exec, compile, and all other built-in functions are available inside the evaluated expression. The validation before eval only checks 1) The function name matches ^[a-z]+[a-z]+ (snakecase pattern) and 2) The function name is in self.registeredfunctions. The arguments to the function are not validated. If an attacker can influence the LLM's generated edit actions (via prompt injection through…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-89g2-xw5c-v95p

  2. Revision 1 · created ·

    Published from osv record GHSA-89g2-xw5c-v95p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42079

Advisory: PPTAgent: Arbitrary Code Execution via Python eval() of LLM-Generated Code with Builtins in Scope
IDs: CVE-2026-42079, GHSA-89g2-xw5c-v95p
Record: https://patchnext.com/advisories/cve-2026-42079 (revision 2, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pptagent 1.1.36. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pptagent: affected < 1.1.36; fixed in 1.1.36

## Suggested inspection (read-only)
- `python -m pip show pptagent`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pptagent.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-89g2-xw5c-v95p (OSV record GHSA-89g2-xw5c-v95p lists affected ranges: PyPI pptagent >=0 <1.1.36 (fixed))
- Verified: https://github.com/advisories/GHSA-89g2-xw5c-v95p (GitHub-reviewed advisory GHSA-89g2-xw5c-v95p lists affected ranges: PyPI pptagent >=0 <1.1.36)

Commands are suggestions: review each one before running it.

Loading voting…