Evolver: Command Injection via execSync in _extractLLM() function allows Remote Code Execution
CVE-2026-42076GHSA-j5w5-568x-rq53
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@evomap/evolver 1.69.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @evomap/evolver
- Affected
- < 1.69.3
- Fixed in
- 1.69.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j5w5-568x-rq53 lists affected ranges: npm @evomap/evolver >=0 <1.69.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j5w5-568x-rq53 lists affected ranges: npm @evomap/evolver >=0 <1.69.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-42076: 1.70% estimated exploitation activity in the next 30 days; percentile 77.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A command injection vulnerability in the extractLLM() function allows attackers to execute arbitrary shell commands on the server. The function constructs a curl command using string concatenation and passes it to execSync() without proper sanitization, enabling remote code execution when the corpus parameter contains shell metacharacters. Details The vulnerability exists in src/gep/signals.js at lines 260-274: The corpus parameter is derived from user input (via userSnippet in extractSignals() function) and flows through to extractLLM() where it becomes part of the shell command. While JSON.stringify() escapes some characters, it does not prevent shell command substitution via $(...) syntax when the resulting string is passed to execSync(). The extractSignals() function is called from the main evolution loop in src/gep/evolver.js, which processes user snippets and session transcripts. PoC Prerequisites: - Node.js installed - Access to the evolver application Steps to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-j5w5-568x-rq53
- Revision 2 · amended ·
Amended from osv record GHSA-j5w5-568x-rq53
- Revision 1 · created ·
Published from ghsa record GHSA-j5w5-568x-rq53
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42076 Advisory: Evolver: Command Injection via `execSync` in `_extractLLM()` function allows Remote Code Execution IDs: CVE-2026-42076, GHSA-j5w5-568x-rq53 Record: https://patchnext.com/advisories/cve-2026-42076 (revision 3, source checked 26 Oct 2026, 12:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @evomap/evolver 1.69.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @evomap/evolver: affected < 1.69.3; fixed in 1.69.3 ## Suggested inspection (read-only) - `npm ls @evomap/evolver --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @evomap/evolver. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j5w5-568x-rq53 (GitHub-reviewed advisory GHSA-j5w5-568x-rq53 lists affected ranges: npm @evomap/evolver >=0 <1.69.3) - Verified: https://osv.dev/vulnerability/GHSA-j5w5-568x-rq53 (OSV record GHSA-j5w5-568x-rq53 lists affected ranges: npm @evomap/evolver >=0 <1.69.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…