Evolver: Path Traversal via --out flag in fetch command allows Arbitrary File Write
CVE-2026-42075GHSA-r466-rxw4-3j9j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@evomap/evolver 1.69.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @evomap/evolver
- Affected
- < 1.69.3
- Fixed in
- 1.69.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r466-rxw4-3j9j lists affected ranges: npm @evomap/evolver >=0 <1.69.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r466-rxw4-3j9j lists affected ranges: npm @evomap/evolver >=0 <1.69.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- EPSS
- CVE-2026-42075: 0.64% estimated exploitation activity in the next 30 days; percentile 50.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A path traversal vulnerability in the skill download (fetch) command allows attackers to write files to arbitrary locations on the filesystem. The --out= flag accepts user-provided paths without validation, enabling directory traversal attacks that can overwrite critical system files or create files in sensitive locations. Details The vulnerability exists in index.js at lines 752-767: The outFlag.slice('--out='.length) extracts the user-provided path without any sanitization or validation. An attacker can provide paths like ../../../etc/cron.d to write files outside the intended directory. Note: The safeId variable is sanitized via inline replacement (replace(/[^a-zA-Z0-9\-\.]/g, '')), but this sanitization only applies to the default path, not to the user-provided --out= path. PoC Prerequisites: - Node.js installed - Access to the evolver application Steps to reproduce: 1. Create a test file demonstrating the vulnerability: 2. Run the test: Expected output: Actual exploit…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-r466-rxw4-3j9j
- Revision 1 · created ·
Published from osv record GHSA-r466-rxw4-3j9j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42075 Advisory: Evolver: Path Traversal via `--out` flag in `fetch` command allows Arbitrary File Write IDs: CVE-2026-42075, GHSA-r466-rxw4-3j9j Record: https://patchnext.com/advisories/cve-2026-42075 (revision 2, source checked 26 Oct 2026, 12:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @evomap/evolver 1.69.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @evomap/evolver: affected < 1.69.3; fixed in 1.69.3 ## Suggested inspection (read-only) - `npm ls @evomap/evolver --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @evomap/evolver. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r466-rxw4-3j9j (OSV record GHSA-r466-rxw4-3j9j lists affected ranges: npm @evomap/evolver >=0 <1.69.3 (fixed)) - Verified: https://github.com/advisories/GHSA-r466-rxw4-3j9j (GitHub-reviewed advisory GHSA-r466-rxw4-3j9j lists affected ranges: npm @evomap/evolver >=0 <1.69.3) Commands are suggestions: review each one before running it.
Loading voting…