OpenClaude Sandbox Bypass via Model-Controlled dangerouslyDisableSandbox Input
CVE-2026-42074GHSA-m77w-p5jj-xmhg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaude 0.5.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaude
- Affected
- < 0.5.1
- Fixed in
- 0.5.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m77w-p5jj-xmhg lists affected ranges: npm openclaude >=0 <0.5.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m77w-p5jj-xmhg lists affected ranges: npm openclaude >=0 <0.5.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-42074: 0.59% estimated exploitation activity in the next 30 days; percentile 48.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The dangerouslyDisableSandbox parameter is exposed as part of the BashTool input schema, meaning the LLM (an untrusted principal per the project's own threat model) can set it to true in any tooluse response. Combined with the default allowUnsandboxedCommands: true setting, a prompt-injected model can escape the sandbox for any arbitrary command, achieving full host-level code execution. Details The vulnerability exists in the shouldUseSandbox() function in src/tools/BashTool/shouldUseSandbox.ts (lines 130–153): The second guard, areUnsandboxedCommandsAllowed(), is defined in src/utils/sandbox/sandbox-adapter.ts (lines 474–477) and defaults to true: This means that out of the box, with default configuration, the LLM can bypass the sandbox for any command simply by including "dangerouslyDisableSandbox": true in its tool call input. The project's own trust model states: "The model/agent is not a trusted principal. Assume prompt/content injection can manipulate behavior." Yet…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-m77w-p5jj-xmhg
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-m77w-p5jj-xmhg
- Revision 1 · created ·
Published from ghsa record GHSA-m77w-p5jj-xmhg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42074 Advisory: OpenClaude Sandbox Bypass via Model-Controlled `dangerouslyDisableSandbox` Input IDs: CVE-2026-42074, GHSA-m77w-p5jj-xmhg Record: https://patchnext.com/advisories/cve-2026-42074 (revision 4, source checked 26 Oct 2026, 12:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaude 0.5.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaude: affected < 0.5.1; fixed in 0.5.1 ## Suggested inspection (read-only) - `npm ls openclaude --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaude. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m77w-p5jj-xmhg (GitHub-reviewed advisory GHSA-m77w-p5jj-xmhg lists affected ranges: npm openclaude >=0 <0.5.1) - Verified: https://osv.dev/vulnerability/GHSA-m77w-p5jj-xmhg (OSV record GHSA-m77w-p5jj-xmhg lists affected ranges: npm openclaude >=0 <0.5.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…