beets has a Cross-site Scripting vulnerability
CVE-2026-42052GHSA-3gxm-wfjx-m847
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (beets 2.10.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI beets
- Affected
- < 2.10.0
- Fixed in
- 2.10.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3gxm-wfjx-m847 lists affected ranges: PyPI beets >=0 <2.10.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3gxm-wfjx-m847 lists affected ranges: PyPI beets >=0 <2.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
- EPSS
- CVE-2026-42052: 0.30% estimated exploitation activity in the next 30 days; percentile 22.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
During code logic analyis, an area that may lead to unintended behavior under specific conditions was discovered. Overview - Verified Version: 80cd21554124da07d17a4f962c7d770a4f70d0f2 - Vulnerability Type: Stored XSS - Affected Location: beetsplug/web/templates/index.html:42 - Trigger Scenario: Metadata fields such as title, lyrics, or comments are rendered with raw template interpolation and inserted into DOM via .html(...). Root Cause The bundled web UI uses Underscore template interpolation mode <%= ... % for untrusted metadata fields. In this runtime, <%= ... % is raw insertion and HTML escaping is only performed by <%- ... %. Rendered output is then inserted with .html(...), allowing attacker-controlled markup to become active DOM. Source-to-Sink Chain 1. Source (attacker-controlled input) - Item metadata values (for example title, lyrics, comments) can contain attacker HTML payload. 2. Data flow - Templates in beetsplug/web/templates/index.html:42-46,87-91 render metadata with…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-3gxm-wfjx-m847
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-3gxm-wfjx-m847
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42052 Advisory: beets has a Cross-site Scripting vulnerability IDs: CVE-2026-42052, GHSA-3gxm-wfjx-m847 Record: https://patchnext.com/advisories/cve-2026-42052 (revision 3, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: beets 2.10.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI beets: affected < 2.10.0; fixed in 2.10.0 ## Suggested inspection (read-only) - `python -m pip show beets`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on beets. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3gxm-wfjx-m847 (OSV record GHSA-3gxm-wfjx-m847 lists affected ranges: PyPI beets >=0 <2.10.0 (fixed)) - Verified: https://github.com/advisories/GHSA-3gxm-wfjx-m847 (GitHub-reviewed advisory GHSA-3gxm-wfjx-m847 lists affected ranges: PyPI beets >=0 <2.10.0) Commands are suggestions: review each one before running it.
Loading voting…