Skip to content

← Actionable
Medium, CVSS 4.8amended

Axios: Authentication Bypass via Prototype Pollution Gadget in validateStatus Merge Strategy

CVE-2026-42041GHSA-w9j2-pvgh-6h63

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (axios 1.15.1, 0.31.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm axios

    Affected
    >= 1.0.0, < 1.15.1<= 0.31.0
    Fixed in
    0.31.1, 1.15.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-42041: 0.66% estimated exploitation activity in the next 30 days; percentile 51.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerability Disclosure: Authentication Bypass via Prototype Pollution Gadget in validateStatus Merge Strategy Summary The Axios library is vulnerable to a Prototype Pollution "Gadget" attack that allows any Object.prototype pollution to silently suppress all HTTP error responses (401, 403, 500, etc.), causing them to be treated as successful responses. This completely bypasses application-level authentication and error handling. The root cause is that validateStatus is the only config property using the mergeDirectKeys merge strategy, which uses JavaScript's in operator — an operator that inherently traverses the prototype chain. When Object.prototype.validateStatus is polluted with () = true, all HTTP status codes are accepted as success. Severity: High (CVSS 8.2) Affected Versions: All versions (v0.x - v1.x including v1.15.0) Vulnerable Component: lib/core/mergeConfig.js (mergeDirectKeys strategy) + lib/core/settle.js CWE - CWE-1321: Improperly Controlled Modification of Object…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-w9j2-pvgh-6h63

  2. Revision 1 · created ·

    Published from osv record GHSA-w9j2-pvgh-6h63

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42041

Advisory: Axios: Authentication Bypass via Prototype Pollution Gadget in `validateStatus` Merge Strategy
IDs: CVE-2026-42041, GHSA-w9j2-pvgh-6h63
Record: https://patchnext.com/advisories/cve-2026-42041 (revision 2, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: axios 1.15.1, 0.31.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm axios: affected >= 1.0.0, < 1.15.1; <= 0.31.0; fixed in 0.31.1, 1.15.1

## Suggested inspection (read-only)
- `npm ls axios --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on axios.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w9j2-pvgh-6h63 (OSV record GHSA-w9j2-pvgh-6h63 lists affected ranges: npm axios >=1.0.0 =0 <0.31.1 (fixed))
- Verified: https://github.com/advisories/GHSA-w9j2-pvgh-6h63 (GitHub-reviewed advisory GHSA-w9j2-pvgh-6h63 lists affected ranges: npm axios >=1.0.0 =0 <=0.31.0)

Commands are suggestions: review each one before running it.

Loading voting…